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Introduction
1.1

What is Nvu? – What does it do?

Nvu is a complete Web Authoring System which integrates web page development and web file
management.
It provides a web page editor which has a simple graphical (wysiwyg – what you see is what you
get) interface. With Nvu, newcomers will quickly and easily be able to produce new web pages
and existing pages may be easily updated
Alternative editing ‘views’ of the pages are provided right down to detailed code level.
The output code is compliant to a high extent with the latest issues of the appropriate web
language specifications and pages may be checked for validity directly from Nvu using the
official W3C validator.
Nvu incorporates a Site Manager this gives rapid access to the files on both local machines and
remote servers. It can cater for several sites and switch rapidly between them.
From within Nvu pages and associated files may be uploaded to a remote server.
Nvu supports the use of “Styles” through Cascading Style sheets (CSS) both embedded and
external. It has an editor which generates CSS code conforming with CSS 2.1 specifications.

1.2

Who is Nvu for?

Nvu appears suitable for anyone wishing to have a modern, free of charge, program for
developing small web sites and who would like to learn modern web design techniques such as
the use of CSS.

1.3

Scope of the guide

The guide has been written from the point of view of the Windows Operating system so details
may differ for other systems. It is intended as a reference document although in a few places it
uses a tutorial approach.
Although web pages can appear on screen, in print or in audio the guide is confined to on-screen
uses.

1.4

Methodology

The approach taken by the guide attempts to satisfy the needs both of the comparative novice
who has little knowledge of web design tools, and those making the transition from other tools
and who may have considerable knowledge of the field.
Although the Guide is not intended for the complete beginner, concepts are introduced
progressively and gradually added to. To avoid being too repetitive I have, in a number of places,
referred to subjects yet to come. This applies, in particular to the use of styles in which Nvu is
strong. I suggest that these references are disregarded at first reading and come back to later.
This will not prevent understanding later parts.
Those in a hurry wanting details of some particular feature and no more are recommended to
the pdf version of the Guide which has a full subject index.

Issued 10-June-2006 based on Nvu version 1.0
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2 Quick start
2.1

Open Nvu

The main window opens. At the top are a number of toolbars. The topmost is the
Menu Bar. This carries a number of items (File, Edit etc) used to make selections.
The next is the ‘Composition Toolbar’ which carries a number of ‘Buttons’ labelled
‘New’, ‘Open’ etc.

2.2

To create a new page:

On the Composition toolbar Click the ‘New’ button.

2.3

To open an existing page

Assuming that the page is stored on your local disk in HTML format:
On the menu Bar click ‘File’ then ‘Open File’. Browse to the file and click ‘Open’.

2.4

Editing a web page

Your web page – blank or otherwise – is in the large pane in the centre right of the
Nvu application window. Many editing functions are very similar to those in a word
processor. The top four toolbars on the Nvu application window provide a number
of editing functions – to see what any do hover the cursor over an item and a hint
will appear.

2.5

Saving a Page

To save a page:
On the Composition toolbar click ‘Save’.
If it was a new document a dialog window will ask you to enter a title for the page.
This will appear in the tab at the top of the page display area. NB this is NOT the
file name. Click ‘OK’; you will then be offered a normal save window which allows
you to browse to a suitable location and name the file. The file type offered will be
HTML.

2.6

Browsing a page

To see how your page will look in your default browser on the Composition toolbar
click ‘Browse’.

2.7

Help

The Nvu help system is gradually becoming more comprehensive and should be
a first resort in case of need. There is a useful Tutorial for beginners available as
an extension to Nvu. It needs to be installed separately; for instructions go to
http://ghaint.no-ip.org:8942/~k2/moz/nvutut.xhtml
Once installed the tutorial will be accessible via Help > Nvu Tutorial.
Issued 10-June-2006 based on Nvu version 1.0
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3 Using Nvu
Menu Bar
Composition Toolbar
Format Toolbar (1)
Format Toolbar (2)
Page tab
Rulers
Page Area
Site Manager
Edit mode toolbar
Status bar

3.1

Finding your way around

When Nvu starts the window carries a menu bar across
the top (File, Edit, View etc). Below this are three of
'Toolbars'. To ensure that everything is visible select
View > Show/Hide and see that each of the following is
checked: Composition Toolbar, Format Toolbar, Edit
Mode Toolbar, Status bar, Rulers, Site Manager.
The three toolbars across the top of the window carry
buttons (represented by icons). Hover on any to find its
function. If any are greyed out they are not functional in
the current mode as they are context sensitive.
Note Not all buttons are installed initially. The full list is
given in section 9.2.

At the bottom of the window is the 'Status Bar'.
Across the centre of the window are two panes: the 'Site
Manager' on the left and a blank web page on the right.
The Site Manager is a powerful tool which is covered in
section 8. Since it is not needed yet it may be closed by
clicking on its close button or pressing F9.

modes’ for a page (‘Normal’, 'HTML Tags', 'Source',
'Preview'.)
For details of viewing modes see section 3.15.
Note The figure shows the buttons as they appear
when Nvu is first installed. They may be customised to
different arrangements (see section 9.1). If this has
been done some of the following may be difficult to
follow. To restore defaults click View – Show/Hide >
Customize Toolbar > Main Toolbar > Restore Default
Set and repeat similarly for the Format Toolbar.

3.2

Starting a page

A new page can be created either from a blank page or
by opening any pre-existing page.
Note There are often several ways of getting Nvu to do
something. This guide will use the button on the
Composition toolbar if that is available. For menu
equivalents see section 9.4 ‘Setting Preferences –
Toolbars’.

3.2.1 Document types (Doctype)

Web pages use the HTML (HyperText Markup
Language). There are number of variants of the basic
language some details of which are outlined in Appendix
3. Nvu is capable of creating and editing four variants
but for simplicity of explanation I recommend that users
create the Strict HTML variant. I also recommend that
you go the menu item Tools > Preferences and check
At the bottom of the page area is the ‘Edit Mode Toolbar’
the box 'Use CSS Styles instead of HTML Elements ...'
which carries four tabs which select one of four ‘Viewing
this will give you the maximum functionality. You can
edit documents which have been originated in other
At the top of the Page area there is a Page tab which
carries the name of the page (‘Untitled’). (Nvu Help
refers to this as the ‘Tab Browser’ toolbar.) If you had
several pages open, as shown in the figure, this tab
would allow you to select one them rapidly.
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variants and again 'Use CSS Styles ...' gives maximum
functionality.
Note If you find a button or menu item disabled it is
likely to be a because 'Use CSS Styles ...' is not set but
could be because of the context of the action.

3.2.2 Options for starting a page
There are several ways to start new pages or open
existing ones.
To start a new blank page.
On the menu bar click File > New.
A window headed ‘Create a new document or template’
appears. Check the boxes ‘A blank document’ and
‘Strict DTD’ and clear ‘create a XHTML document’.
(Without Strict DTD checked the document would have
‘Transitional’ DTD.)
Note The next time you want to repeat this action
simply click the ‘New’ button on the Composition
toolbar, the selections previously made will be
remembered.

Nvu supports many levels of Undo and Redo, however
changes made in ‘Source’ view cannot be undone after
you have changed the view.
3.3.1 Tutorial – Brief introduction to HTML
HTML stands for HyperText Markup Language. It is the
publishing language of the World Wide Web on which
Nvu is based. Ideally it should be possible to use Nvu
without any knowledge of this language and certainly
without a knowledge of the details. As a precaution
however a limited understanding is desirable. This
tutorial covers a minimum of detail while introducing
some useful features of Nvu.
Click on the '<> Source' tab. You will see a number of
terms enclosed within angle <> brackets. These are
HTML ‘Tags’. Everything starting from the <body> and
finishing with </body> will appear on your web page.
Note In most cases tags occur in pairs – opening tags
and closing tags – Closing tags always start with a
forward slash.

All the page consists of now is a <br> tag which is a line
break and which is, of course, invisible.
To open an existing page.
Later as a page builds up many more tags will be
added. For the most part the pairs of tags enclose
Either:
‘contents’ from which the page is built up – items like
Paragraphs, Headings, Tables, Images. The tags plus
Click the OPEN button to access a normal
the contents are called ‘elements’. The tags names are
browse dialogue.
usually either the same as element names or
Click File > Recent Pages to get rapid access to
abbreviations of them. Some examples are ‘table’, ‘img’
those recently worked on.
for image, ‘p’ for paragraph, ‘br’ for line break (which is
unusual in having no closing tag).
Or use the Site Manager (Section 8) which
provides a powerful mini-browser and is very
Nothing between the <head> and </head> tags will
easily set up.
appear on the screen but may have quite useful
functions nonetheless. For instance, between the <title>
The doctype of an existing page will remain the same as
and </title> tags there isn’t anything. Go for it, between
before it was opened. It cannot be changed in Nvu.
them type “My first page” or something like that. Click
Each page opened starts in a new tab which can be
the tab for ‘Normal’ view, now the tab at the top carries
clicked to select a document to work on.
your page title and you’ve edited raw HTML. Well done!
If you were too timid to do this all is not lost. There is no
3.3 Editing in Nvu
need to use source view at all. Go to Format > Page
Nvu supports all the standard Windows editing
Title and Properties. Here you can enter various
commands and shortcut keys. e.g. Copy Ctrl+C, Paste
parameters including the title and the language you are
Ctrl+V etc. There are other Nvu specifics. These are
writing in. These will be entered in the HEAD area for
great time savers.
you. In some circumstances they can be important; the
Title and Description, for instance, can be used by
Tip: The plus sign (+) means that you must press two
search engines to index the page.
keys surrounding the plus sign at the same time.
Back to '<> Source'. Notice the first tag is <html> and
In ‘HTML Tags’ view Nvu supports drag and drop editing the last </html>. All web pages must carry these in these
for block items. (Select an item by pressing the Control
positions. Actually the case doesn’t matter for any tag
key while clicking on the Tag.)
though it’s good practice to use lower case.
The first line, in a different colour, specifies the
An extreme time saver is Nvu’s double click response.
‘Doctype’. This is a reference to the type of HTML
In several cases, such as links, images and tables, a
document. Nvu determines the doctype according to the
very useful editing window is opened.
options selected on starting a page.
Finally, give the document a name and save it.
The use of templates is covered in section 7.

Issued 10-June-2006 based on Nvu version 1.0
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3.3.2

Saving files

a paragraph. To start a new line within the current
paragraph press Shift+Enter this generates a line break.

You are offered a ‘Save Page as’ window which allows
you to browse to the folder you want to use. You will find
Note This is the default action and can be altered. (See
Setting Preferences section 9.2.4)
the file name already completed with your page title.
You will probably want to change this to a shorter, all
Other standard text formats are Heading formats from
lower case, name (but you don’t have to). You will find
Heading 1, the largest, to Heading 6, the smallest.
the file extension completed as ‘html’ you may well
Browsers generally render headings in bold type.
prefer to, and you may alter it to “htm”.
Text can be edited in any of the viewing modes and Nvu
Note If you have hidden extensions for file types
responds to all the normal windows shortcut commands.
this becomes unavailable. Hide or view
extensions is controlled in Windows by Control
3.4.1.2 Block or Inline
Panel > Folder options > View then scroll down
The elements just described mark out ‘blocks’ of text.
and clear "Hide extensions for known file types".
Blocks usually begin on a new line.
After you edit files you need to re-save. Click the ‘Save’
Blocks have gaps above and below controlled by
button.
margins and padding (see section 4.2.1.4).
There is nothing mysterious about the files. The curious
may open the file using any text editor e.g. Windows
Vertical margins ‘collapse’ i.e. The larger margin is
notepad. What you will see will look just like the HTML
applied the smaller is ignored.
Source code you’ve been looking at in ‘Source’ view.
Tip: The outline of each block of text can be
This shows that the source is just a simple text
revealed by selecting View >Block outline. The
document.
dimensions of each block in pixels are shown on
Tip: Filenames should generally be composed of
the rulers at the top and side of the page.
unaccented letters, numbers and the underscore
Within blocks it is possible to mark out sections of
character. Some others are permissible but the
‘inline’ text.
rules for incorporating them are more complex.
Inline text does not usually start a new line.
Tip: Web pages are stored (hosted) on servers
which usually run either a version of Windows or
3.4.2 Formatting text
UNIX operating systems. UNIX filenames are caseTip: Text to be formatted may be selected in one
sensitive while Windows are not. For this reason if
of several ways.
you use mixed cases in filenames you must be very
rigorous. A site which runs perfectly in your local
Simply place the cursor anywhere in a block.
Windows environment or on a host running WinWhere the formatting desired can only apply to
dows if transferred to a UNIX system might require
a complete block this is sufficient.
extensive and time-consuming changes.
Double-click within a block to select a word.
3.3.3 Printing pages
Triple click within a block to select a line of text.
The ‘Print’ button allows you to print the current
page to a printer. This prints the page view and
not the source code.

Drag across a section of text to highlight and
select that section only.

3.4

In HTML Tags view press the Control key while
clicking on the tag for the block to select the
complete block.

Working with text

3.4.1 Text on a page
3.4.1.1 Introduction
Text typed directly onto the Nvu page defaults to
appearing in the format for the ‘body’ element. HTML
defines a small number of elements specifically for text
and it is usually preferable to use these.
To format text in a standard element format select the
text (it is actually necessary simply to click anywhere
within the block of text) and click the first drop-down box
on the format toolbar. This offers a selection of standard
text formats. Paragraph is the most appropriate for
general text.
Once formatted as a paragraph, when typing in a text
area, use of the ‘enter’ key starts a new block of text i.e.
Issued 10-June-2006 based on Nvu version 1.0
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Text can be formatted in a number of ways using the
format toolbar. The changes listed in the table can be
applied (hover over a tool to discover what it does).
Choose a Font *
Choose text colour *
Choose background colour *
Choose highlight colour *
Make text smaller *
Make text larger *
Embolden *
Italicise *
Underline *
Format as a numbered list Format as a bulleted list
Align left
Align Centre
Align right
Justify
Indent text
Outdent text
Emphasise *
Strongly Emphasise *
Note 1 For the options marked with an asterisk select
an inline section of text. This allows you to have a few
words in a paragraph of a different size etc. (When you
do this, if you use the 'HTML Tags' view, you will see
the start of the change marked with a ‘Span’ marker.)
Note 2 'Choose background color' sets the colour for
the background of the current block. If 'Use CSS Styles
...' is not checked it changes the background colour for
the complete page.
Note 3 The emphasis button will result in italicised text
with most browsers and the strong emphasis button in
bold text.
Warning. With Nvu 1.0 when using Strict Doctype
check 'Use CSS styles instead of HTML elements and
attributes' in Tools > Preferences > General to ensure
availability of all options.

3.4.3

Positioning text

Generally the position of text is determined by the fact
that one block flows on after the previous one etc.
The space between blocks is determined by the
browser. Through the use of styles (see Section 4.2.1.4)
these settings can be altered.

edge of the ruler and draw it half way across the
window. Do the same for the other paragraph but take
the right edge of the ruler and drag it half way to the
centre but in the opposite direction.
You probably think that you’ve achieved a rather elegant
layout and discovered a flexible tool. Drag the window to
be wider then narrower. Do you still think so? What you
have done is to set the text to be in a fixed position and
of fixed width. It no longer re-flows. Consider that visitors
who view your pages may have smallish or very large
screens. Will they all see what you want them to?
Supposing that you don’t like what you have just done –
you can just Undo it – Edit > Undo or Ctrl+Z. However if
you leave it to later you would first have to undo all later
work. You can re- or de-format a paragraph directly and
individually. This allows you precise control rather than
relying on dragging the ruler. Go to 'HTML Tags' view,
click on the yellow 'p' marker for a paragraph, on the
status bar right-click on the highlighted 'p' area and
select ‘Inline styles’. Now select ‘Box Properties’. This
allows precise editing of the paragraph within the ‘box’ in
which it is contained. If you clear everything and click
“OK’ you’ll be back on virgin territory. Alternatively you
can set it up precisely.
3.4.4

Lists

3.4.4.1 Numbered and Bulleted lists
Nvu can format a list of items giving each item a
sequential number in any of several formats (HTML calls
these ordered lists <ol>) or presenting them bulleted
(unordered lists <ul>).
To start a list from scratch
1 Click one of the list buttons (Numbered List or
Bulleted list) on the Format toolbar.

Paragraph and heading blocks stretch from one side of
the screen to the other. This a very elegant way of
operating. Try resizing the Nvu window. Until it becomes
so narrow that nothing can fit, the text reformats so that
it still fits – though narrower it becomes longer. It is
fundamental to the way the web operates that it is
designed for information transmission and not
presentation. Web design tools allow us to refine
presentation but, if we over constrain it, we may run into
problems of getting it to fit on the screen. We really
should allow the browser as much freedom as possible.

2 Type the first item.

3.4.3.1 Fixed width text
Nvu allows you to constrain the width of paragraphs.
(The same applies to headings.) Try this. Set the
window size so that it is somewhat narrower than the full
screen width i.e. so that you have space either to narrow
it more or to widen it.

To add items to a list

3 Press Enter and type the next item.
4 To finish, on the last (blank) item press Enter
To change existing text into a list
1 Select the text required.
2 Click one of the list buttons on the Format Toolbar.
The text will be changed into a list a new item starting
for each paragraph or other block item encountered.

1 Click at the end of the last item in the list.
2 Press Enter and type the new item.
Numbering and format will continue from the previous
item.

Take two longish but similar paragraphs which fill about
half of the window. Click in one, you will see the rulers
both across the top and down the side. Grab the left
Issued 10-June-2006 based on Nvu version 1.0
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3.4.4.2 Formatting lists
To change the formatting for a list click in the list and, on
the menu bar, select Format > List and choose the
preferred option. More options are available via the List
properties option (which is also accessible by rightclicking in the list).
For numbered lists the numbering style may be
selected, for bulleted lists the type of bullet may be
changed.
3.4.4.3 Nesting lists
Lists can be nested.
To start a new level of list within an existing list
1 Click at the end of the line preceding the new list to
be generated.
2 Press Shift + Enter
3 Click a list button on the format toolbar.
4 Type the content of each list item followed by Enter.
Each level of list in a nested set may have either the
same or different format which may be set as above.
Nvu sets no format by default. Browsers normally by
default render all numbered lists with decimal number
format but each level of bulleted lists using a different
bullet symbol.
3.4.5

More formatting

The menu selection FORMAT offers many ways of
formatting text. In some cases you can simply click
within the text region in others you must select the
section of text involved. Some of the effects may be
repeated several times for more effect, some will
reverse on a second application.
The options offered include indenting text. Those
unfamiliar with web design may look, in vain, for a tab
option. HTML does not support tabs although the List
feature does produce a tabbed effect. Nvu substitutes
for this in that pressing the Tab key introduces several
spaces – of course these do not produce the alignment
effects that real tabbing would. The spaces introduced
by the Tab key are technically known as non-breaking
spaces. Pressing the space bar more than once also
introduces non-breaking spaces.
3.4.6

Importing text

Strictly Nvu does not support importing text from other
applications but it is possible to copy and paste text.
In normal view content from other web pages may be
copied reliably. The result will be rendered according to
any styling applied in your document; any reliance on
external styles in the original document will we lost. See
section 4 for more on styles.

such as Windows notepad may also be copied and
pasted.
When such text is pasted into Nvu most formatting is
lost but block divisions (paragraphs or headings) are
retained. Text will be pasted into the selected element
e.g. Body or ‘p’. If several paragraphs are pasted into a
‘p’ element they will be rendered as individual
paragraphs. If they are pasted into the body, by
selecting them all and re-formatting as ‘paragraph’, the
individual paragraphs will be revealed.
Numbered lists will be retained.
Tabs will be rendered as three non-breaking spaces.
The contents of tables may be pasted, individual cells
will be separated as if by tabs.
3.4.7

Special characters

By special characters we refer to characters which do
not have an equivalent keyboard key. HTML supports a
large range of characters including all the international
currency symbols. A number of the more common,
including accented ones, may be inserted using Insert >
Characters and Symbols.
Nvu does not directly support ‘smart quotes’ but text
which has been copied from applications like Microsoft
Word or OpenOffice.org which include smart quotes will
retain these details and they will be correctly rendered in
browsers.
If you need a character which is unobtainable by these
methods it can be inserted by editing the file in ‘Source
view’. See section 3.16. Characters may be inserted
either using the decimal code for the character or using
a mnemonic ‘entity’. Precede the decimal code with &#
and the entity with & and follow both with a semicolon.
Use no spaces. The HTML specification (see appendix
2) in section 24 lists the codes.
Some useful examples are:
Character
mrule
nrule
ellipsis
left quote
right quote
left double quote
right double quote
infinity
tilde

—
–
…
‘
’
“
”
˜

Entity

Decimal

&mdash;
&ndash;
&hellip;
&lsquo;
&rsquo;
&ldquo;
&rdquo;
&infin;
&tilde;

&#8212;
&#8211;
&#8230;
&#8216;
&#8217;
&#8220;
&#8221;
&#8734;
&#732;

and so on for other Greek letters

Text from word processors such as Microsoft Word or
OpenOffice.org in rtf or doc format or from text editors
Issued 10-June-2006 based on Nvu version 1.0
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3.4.8

Checking spelling

Simplicity itself. In any view, other than ‘Source’,
click on the ‘Spell’ button. The spell checker will
work sequentially through the page. You will be
offered one dictionary (English United States) but
you can add your own words to it.
By first highlighting a section of a page only that section
will be checked.
It is also possible to run the spell checker all the time.
Any mis-spelled words underlined in red. To set this
option on the Menu Bar select Tools > Preferences. In
the Options window which appears select the
'Advanced’ button and set ‘Underline misspelled words’
– OK.
Warning With Nvu 1.0 this setting must be made after
the page is opened. Otherwise cancel and re-set.
Note Spell checking uses enormous processor
resources. When working on long documents, if your
system grinds to a halt, disable this when not required.

3.4.9

Viewing text

The main page editing pane acts rather like a browser in
that the text size may be viewed at different
magnifications (nothing to do with the code for the final
page). Set this using View > Text Zoom. This has no
effect in Source view.

3.5

Working with images

With Nvu it is easy to insert images on to your page.
Browsers accept images in three formats ‘gif’, ‘jpg’ or
‘png’. You may have to use a graphics package to get
your image into a suitable format. You can insert an
image located anywhere on your computer but, for the
sake of order, it is a good idea to locate any images
which you intend to use either in the same folder
(directory) as your page document or in a sub-folder of
this.
3.5.1

Inserting images

Warning Before inserting an image save your page.
Otherwise Nvu will have difficulty in referencing where
your image is located.

As an exercise set your cursor in the middle of the
paragraph, maybe at the start of a sentence.
To insert an image
1 Click the 'Image' button on the Composition
toolbar.
2 The Image properties window opens. Click 'Choose
File' and browse and select a file
3 Click ‘Open’. Leave checked the box ‘URL is relative
to page location’ this will allow you to move the page
and image to another location, as you will have to
when you upload them to a server. (If you deselect
Issued 10-June-2006 based on Nvu version 1.0

this and move the page, it will try to find the image at
the original location.)
Note If the box is ‘greyed out’ this is probably because
the page has not been saved.

4 In the box labelled ‘Alternate text’ add a description
of the image. (This forms the ‘alt’ attribute for the
image and provides text which will appear in place of
the image with user agents (browsers) that cannot
display images (screen readers and voice
synthesisers). It will also be used by those with visual
impairment. The content of this box must be carefully
considered so as to be of maximum assistance in
such cases.)
Note Where the image is purely decorative, and not
necessary to understanding the page, alternative text is
not required and should be omitted.

5 In the box labelled ‘Tooltip’ you may optionally insert
a ‘Title’ attribute for the image. Most browsers will
show the text provided when the cursor hovers over
the image.
6 Click OK.
3.5.2

Positioning and resizing images

You should see the image inserted into the middle of the
paragraph. Maybe it has come out some ridiculous size.
Click the image. A sizing box appears around the image.
The box has 8 graphical handles (small white squares)
one at each corner of the image and one in the middle
of each side).
Drag on a handle to alter the size of the image. Make it
some sensible size. Dragging a handle in the centre of a
side will alter the shape of the image which is usually
undesirable.
More precise control may be achieved via the Image
properties window described after the note. Select the
‘dimensions’ tab.
Note Ideally images should be produced at the size
required rather than resizing them. Importing large
images and reducing the size wastes bandwidth and
slows presentation. Resizing by small amounts can
introduce undesirable artifacts.

Images in the middle of paragraphs are not usually what
is needed. You can place them at either the right or left
side and have the text wrap round.
To align an image (Method for transitional Doctypes)
1 Click the image.
2 Click the Image button on the Composition toolbar:
this will open the Image properties box.
3 Select the ‘Appearance’ tab
4 In the drop down box ‘Align text to image’ select the
required alignment.
5 Click OK
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Try the various options. The text starting from where the
image is inserted will wrap around the image.
You may prefer the complete paragraph to wrap. Click
on the image and drag the cursor to the start of the
paragraph, or anywhere else. Moving images is easy!

Note If later the table border is set to zero these
outlines disappear but Nvu in normal view replaces
them with a red outline. This does not appear in
Preview or in a browser.

Tables have resizing boxes similar to those used with
images.
You may find the first three options confusing. They
Alternatively for more control
refer to the position of the text relative to the image NOT
the image relative to the text. Specifically you will find no 1 On the Composition Toolbar click the Table button.
The “Insert table” window appears.
way of putting an image in the middle of the page with
2
Click
the ‘Precisely’ tab.
text wrapping around it.
3 Specify the number of rows and columns required.
Note This type of presentation, common enough in
print, is almost impossible to achieve using HTML even
4 Specify the width of the table either in pixels or as a
with full use of styles.
percentage of window size.
5 If a border is required around the table enter the
You may decide that the image is too close to the text,
width in pixels otherwise enter ‘0’. If a border is
that you would like more space around it. Again ‘Image
specified each cell will also have a border but
Properties’ allows this. On the ‘Appearance’ tab set
narrow.
‘Spacing’ Top and Bottom and/or Left and Right as
required. You can also put a border of selected width
Note CSS styles give fuller control of borders. See
section 4.2.1.3.
around a image. The border will be the same colour as
the adjacent text.
For more options
An alternative way of aligning an image is to apply a
Whether created using the ‘Quickly’ or ‘Precisely’ tab the
style via a class as explained in sections 4.2.1.4 and
‘Cell’ tab offers more options.
4.2.3.
a
Alignment of text within cells
3.6 Using tables
b
Wrapping of text
c
Cell spacing - the gap between cells
Tables allow data – images, links, forms, form fields,
d
Cell padding - the gap between the edge of the
other tables, text, etc. – to be arranged into rows and
cell and the text within it.
columns of cells.
A table is basically a rectangular grid forming an array of 3.6.2 Formatting tables
boxes into which the data are placed. The rules,
3.6.2.1 Table size
between the boxes, and the border, around the outside
Tables created using the ‘Quickly’ tab have width set to
of the table, may be either visible or invisible. The boxes
100% of the window size.
are called ‘cells’ and may be coloured. The grid layout
Note Sometimes Nvu creates tables at a different width
does not have to be regular – the first row may have one
in which case this may be altered as given below.
cell the second four, the third three; however, when first
inserted, it will always be regular.
Tables at full window width give the maximum available
W3C recommends “Tables should not be used
space for data. The width accommodates to screen or
purely as a means to layout document content as
window size.
this may present problems when rendering to nonIt is possible to set the width to a smaller percentage of
visual media. Additionally, when used with
window size or to a fixed size in pixels. Fixed sized
graphics, these tables may force users to scroll
tables are inflexible in use and could result in the user
horizontally to view a table designed on a system
having to scroll horizontally to read the content so must
with a larger display. To minimise these problems,
be used with caution. It is also possible to leave the
authors should use style sheets to control layout
width unspecified. This is likely to result in the best
rather than tables.” (HTML 4.01 Specification
presentation as the browser will set the width to the
Section 11.1)
optimal value.
3.6.1 Inserting tables
To adjust table size, with the cursor in the table, click the
To insert a table
table button (or double-click the table). In the Table
1 On the Composition Toolbar click the Table
Properties window select the ‘Table’ tab. The width can
button. The “Insert table” window appears.
be set either as a percentage of window width or in
2 Leave the ‘Quickly’ tab selected and drag out a
pixels. To leave it unspecified clear any number in the
matrix then click the bottom right cell to define the
width box.
table arrangement.
3 The cells appear on the screen with narrow outlines.
Issued 10-June-2006 based on Nvu version 1.0
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It is also possible to adjust the size of a table using the
sizing boxes. When you do this the size is specified in
pixels.

smaller than the table several options are offered e.g.
the image may be centred or tiled horizontally, or
vertically or in both directions until it fills the table.
3.6.2.2 Colouring, adding deleting and merging cells, To apply a background image
rows and columns
5 In 'HTML Tags' view click the tag for the table (or
cell) while pressing the control key.
Right-Click in a table or cell and several menu options
appear which allow the table or cell to be formatted as
6 On the Status Bar right click on the highlighted tag.
desired. Some of the options are context sensitive.
7 Select ‘Inline Styles’, ‘Background Properties’.
‘Table or cell background color’ allows the colour of the
You can then select the tiling and/or position properties
complete table or any cell to be set.
as required.
Note Background images are visible in Normal or
‘Table Insert’ provides means of adding rows, columns,
Preview mode but not in HTML tags view.
individual cells or even tables into a cell.
‘Table delete’ provides the opposite.
3.6.2.4 Setting cell border and spacing
A cell can be joined with the cell on its right, thus
Right-click in a table, select 'Table Cell Properties' and
merging two cells. Virgin cells cannot be split but joined the ‘Table Properties’ window appears. By selecting the
cells can.
'Table' Tab the spacing is revealed as defaulting to 2
pixels between cells. If this is set to zero the gaps
If adjacent cells (whether within a row or column) are
referred to in the previous paragraph disappear.
selected together they can be joined.
Each cell, when clicked, reveals a set of six
manipulation symbols (triangles and circles with x
inside), these provide a rapid method of inserting or
deleting rows and columns of cells as shown in the
figure.

Setting the cell background colour for adjacent cells to a
dark colour reveals gaps between the cells.
This may be convenient if the cells are to be filled with
text as it avoids two items of text abutting each other.
At other times it is a problem. The gap is controlled by
the ‘Cellspacing’ attribute.
3.6.2.3 Background images
It is possible to set a background image for a table or
cell.
The CSS Specification in section 14.2.1 recommends
“When setting a background image, authors should
also specify a background color that will be used
when the image is unavailable. When the image is
available, it is rendered on top of the background
color. (Thus, the color is visible in the transparent
parts of the image).”
The image appears behind anything else in the table. If
the image is larger than the table the table is unaffected
i.e. does not grow to accommodate the image, as much
of the image as will fit is displayed. If the image is
Issued 10-June-2006 based on Nvu version 1.0

Note The ‘Table Properties’ window can also be
accessed from within a table by clicking the ‘Table’
button.

The‘border’ defaults to 1 pixel. This border appears
around the edge of the table and rules appear around
each cell rendering the outlines easily visible. If the
border is set to zero both border and rules disappear.
If the border is set to a value greater than 1 pixel the
rules re-appear and the border appears in the wider
value specified. The exact appearance of the table
border depends on the browser used.
Other aspects of these lines e.g. colour or suppressing
rules when table border is selected cannot be controlled
using these methods.
Note For full control of borders use a Stylesheet (see
Section 4.2.1 especially 4.2.1.3).

The ‘Table Properties’ window also allows the ‘padding’
to be set. Padding is the distance between the cell
content, e.g. text, and the edge of the cell. This provides
an alternative way of establishing space between the
content of adjacent cells. Padding applies to all four
edges of a cell and to all the cells in a table. Once again
use a style for fuller control.
3.6.2.5 Colouring tables
This has already been referred to in section 3.6.2.2. Nvu
however provides several routes to colouring tables or
cells. These include:
Right-click on table and select Table Cell
Properties.
Use Table button to open Table Properties
window.
Right-click in table and select ‘Table or Cell.
Background Color’.
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3.6.2.6 Cell sizes
As you work on a table the sizes of the cells may keep
on changing. It is useful to understand how browsers
treat tables. Unless the size of a table or cell is
constrained in some way a browser will expand the cell
in an attempt to accommodate any text inserted. Other
cells in the same column will have the same width. This
will tend to reduce the space available for any adjacent
column of cells. Eventually the browser will attempt to
balance the allocation to each column by wrapping the
text. The overall effect will probably minimise the total
height of the table.
Tables can have their width completely unspecified,
specified to be a particular width in pixels or some
percentage of window width.
When a table is started the Insert Table automatically
selects the ‘Quickly’ tab. This allows Nvu to make the
decisions. If the ‘Precisely’ tab is selected the user can
make selections specifying the width in pixels or as a
percentage and specifying the border width. Tables
specified as percentage or unspecified are more
accommodating to differing window or screen sizes and
are recommended.
Browsers do not have to slavishly follow instructions. If a
table specification is too narrow to accommodate the
cell contents the table will grow beyond its specified
limit. This can occur if a large image is inserted or a long
word like ‘Antidisestablishmentarianism’.
3.6.2.7 Table properties
The table properties window opens when you

will be converted to table rows a new cell being
generated each time the specified character is met. This
allows tabbed lists to be created and overcomes the fact
that HTML does not support tabs – Simply type a
hyphen (or some other character) instead of the tab and
convert the text to a table.
Using this method tables may be imported from
applications like MS Word. In Word convert the table to
text separating using a character that does not appear in
the text.
Note Do not use tab as the separator as Nvu will
interpret this as several spaces. (See section 3.4.5)

3.6.3.1 Aligning text
Browsers normally display text aligned left and, in the
vertical dimension, in then middle of the cell. To alter
this place the cursor in a cell and click the Table button.
The Table properties window allows the alignment to be
altered. To set the alignment for all cells first select
Table > Select> All Cells.
3.6.4 Centring tables
To align a table to the centre of a page click the table,
right-click ‘Table Cell Properties’, select ‘Table’ and set
‘Table Alignment’ to ‘Center’.
Note For pages using transitional doctypes Internet
Explorer aligns tables left. In the case of IE6 there is a
work around which still produces valid code. In Source
view Edit the HTML code to precede the Table with the
code <div align="center"> and follow the table
with </div>.

3.6.5 Improving tables

Double click a table

There are a number of ways in which tables may be
improved in presentation and accessibility. These
include:
Right click anywhere in a table and select ‘Table
Caption - This is text describing the nature of the table.
cell properties’.
Tables and cells can be re-formatted in many ways. This Insert this using the Table Properties window. The
means that you don’t have to plan everything in advance caption may be positioned on any edge of the table.
Summary - Captions will often be inadequate as a
before you start your table as settings can be adjusted
summary of the purpose and structure of the table from
later.
The table properties window provides an option to insert the perspective of people relying on non-visual user
agents. W3C recommends "Authors should therefore
a caption which can be positioned on any edge.
take care to provide additional information summarizing
Tip. Use HTML Tags view to see where to input the text. the purpose and structure of the table using the
For those familiar with them, the ‘Advanced Edit’ button summary attribute of the TABLE element. This is
gives direct access to inline styles.
especially important for tables without captions." To add
a summary, in the Table Properties window select the
3.6.3 Inserting Text
Table tab and click the Advanced edit button. On the
Inserting text into a table cell is one of the simplest of
HTML attributes tab select the Summary attribute and
tasks. Inserted text will be formatted as a TD element
insert the text in the 'Value' box.
but may be re-formatted as a paragraph or using styles.
Headings - Headings to rows and/or columns improve
Even the simplest of can tasks become tedious if carried
the visual presentation and make the meaning of the
out repetitively possibly copying and pasting from precontent clearer. By default headings are displayed
prepared text.
bolder and centred. Headings are implemented in HTML
After selecting a piece of text Nvu offers a useful facility by replacing td (table data) elements by th (table
via Tables > Create table from selection. Lines of text
header) elements. To change a cell from td (normal cell)
(whether terminated by line breaks or paragraph ends)
to heading select the cell and, using the Table
Click a table and click the table button
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Properties window, with the 'cells' tab selected tick the
'Cell Style' checkbox and set the style to 'Header'.
Accessibility - Adding summaries and headings
represents the first step in improving accessiblity of
tables to non-visual users. HTML offers more powerful
enhancements which improve the performance of text to
speech devices. For more details about this see section
11.4 of the HTML 4.01 specification.

3.7

Links

Links provide the main means of navigating web sites.
They allow you to move quickly from one place to either
another on the same page, a different page on the same
site or a page on an external site. Links may be
attached to any element on a page, in fact almost any
part of a page content can form the basis of a link an
element being generated specifically for the purpose.
Usually however we use a few words of text or an image
which we click on to activate the link.
3.7.1

Linking text

3.7.1.1 Linking to another file
To create a link
1 Select (highlight) a few words of text.
2 On the Composition toolbar click on the ‘Link’
button, alternatively Right click and select
‘Create Link’. The ‘Link Properties’ window
opens.
3 Click on 'Choose File' and browse to the file that you
want to link to.
4 Click OPEN.
In Normal or Preview mode you will now find your text
underlined and in a different colour (probably blue) You
can now try double-clicking on the text, you will see the
'Link Properties' pop up again. This can be very useful if
you want to change the file to which the link refers. (In a
browser you would expect the file viewed to be replaced
by the one to which the link refers!)
If you now switch to 'HTML Tags' view you will see your
text preceded by a yellow marker with an 'A' in it. Your
text has been defined as an 'A' (Anchor) element.
3.7.1.2 Inserting an email address
Instead of linking to a file it is possible to insert an email
address. The result will be that, in use, when the link is
clicked the email client on the visitor’s machine will be
opened with the correct address selected.
To do so proceed as under the previous heading. When
the Link Properties window opens (or if Image
Properties click the Link tab) enter the email address
and check the box ‘The above is an email address’

as a type of bookmark defining a particular place on a
page. Links can jump to such bookmarks.
To insert a named anchor
1 Place the cursor at the point you want to mark.
2 Click the 'Anchor' button on the Composition toolbar
or, on the Menu Bar, select Insert > Named Anchor.
The named anchor properties window appears.
3 Enter a unique name for the anchor.
4 Click OK.
In 'HTML Tags' view this time the yellow marker has a
picture of an anchor.
Note The anchor is also visible in Normal view (but not
in Preview).

3.7.1.4 Linking to named anchors
Start as above for linking to another file. When the 'Link
Properties' window opens, instead of choosing file use
the drop down list. Your anchor name should appear
there preceded by a “#”. Click it and OK. That’s it! If you
test your page on a browser when you click the link the
view should move to show the position of the anchor.
Note If your page is short you may not notice this. You
need to test with a long page with the link towards the
bottom and the anchor towards the top. With most
browsers the anchor should be sit on the top visible
line.

3.7.1.5 Bigger jumps
You can jump directly to the position of named anchors
in other pages. Nvu does not make this quite so easy to
achieve. Proceed as in ‘Linking to another file’ above.
After you have chosen the file and clicked 'Open' you
will see the name of the file in the box, immediately after
this type ‘#’ immediately followed by the name of the
anchor. Thus, if your file was called “pagetwo.html”
and the anchor was called “p2anchor” the complete
entry should read “pagetwo.html#p2anchor” (without
the quotes). Be very careful to get the case of the text
right. With some systems it doesn’t matter but with
others your link will fail if the case is wrong. (I
recommend always using lower case for filenames and
anchors.)
Note The anchor name is ‘p2anchor’ NOT
‘#p2anchor’. The number symbol merely tells a
browser that the following text is an anchor.

You can also, and extremely usefully, jump to pages or
places on other web sites. All you have to do is the enter
the full URL (Web address) into the box. Again be very
careful about getting the case correct. Make sure that
the check box (‘URL is relative to page location’ is
cleared (you may have no option).

3.7.1.3 Inserting named Anchors
While you can link to named anchors on other sites I
suggest that you don’t do this. Confine yourself to linking
There is a second type of Anchor element the ‘Named
anchor’. Such an anchor is extremely useful as it can act to the home page (usually ending /index.htm). To link to
Issued 10-June-2006 based on Nvu version 1.0
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other pages or anchors presupposes that the
webmaster will not re-arrange the structure of the site –
in the end your visitors may land up with links that don’t
work.

3.8

3.7.1.6 Link colours
Links are normally underlined and in blue text. If you
look carefully you may see the colour change and
wonder why. Links can exist in several states the
principal are:

Nvu does not support frames – at least not at present. If
you open a frame document, you get a message ‘This
page can’t be edited for an unknown reason’ but it
displays the frame content rather beautifully. Then you
can do nothing with it except click on the ‘Source’ tab.
You then see the source code and the system will seem
to lock up. Actually it doesn’t lock and you can load
another page and revert to normal operation.

q unvisited links
q visited links
q hovered

the initial state
have been visited in the past
cursor now hovering over

While these probably appear in different colours it is the
browser which determines this.
Note For Transitional doctypes Nvu offers a means of
altering the colours via Tools > Preferences > New
Page Settings. New pages should use the new
selections (they don’t affect the currently open page).
A better way to gain full, reliable control is to clear ‘use
custom, colors’ and set link colours using styles. See
Section 4.2.5.2.

3.7.2

Linking images

The techniques and possibilities are very similar to
those used with text.
To create a link
1 Click on the image
2 On the composition toolbar click on the ‘Link’ button,
alternatively right-click and select ‘Create Link’. The
‘Image Pproperties’ window opens.
3 Click on ‘Choose File’ and browse to the file that you
want to link to. (The box ‘URL is relative to page
location’ is checked. This means that if you move
your page to a new folder you should move the
image to a corresponding new folder. If you clear this
box the absolute address of the image on the hard
drive is given in full. If you move your page now it will
look there for the image. As you start to organise a
web site you will find that this is not a good
arrangement and potentially disastrous when you
upload the page to a server.)
4 Click OPEN
5 Click OK

Frames

If you don’t know what frames are read no further –
you’ll be no worse off.

This is not a great limitation. Though the code for frames
takes a little getting used to it is usually quite short and
can easily be produced using a text editor. Once
established it probably rarely needs to be altered. You
can use Nvu to develop the pages that go into the
frames.
Frame-like presentations can be simulated using CSS.
http://www.nvu.com/demos/frames/frameSimu
late.html provides useful guidance which works well
with Mozilla type browsers but less well with Internet
Explorer.

3.9

Forms

3.9.1 Introduction
Forms provide a mechanism by which a visitor to a site
may send data to as sever for processing. This may be
as simple as a box to write a message for ‘e-mailing’ or
as complex as looking up items from a catalogue and
sending an order to a supplier. Forms collect data typed
in or collected from check boxes or lists and pass them
to the server. It follows that forms can be used only in
association with compatible software running on the
server.
Forms may be placed on standard web pages and act
as block level elements. In normal view Nvu shows
forms surrounded by a dotted cyan box. Forms may
contain other standard block level elements
(paragraphs, headings ...) as well as several specific
elements known as ‘form controls’ which are designed
for data collection. Since these form controls are
essentially inline elements they must be laid out inside
block level elements (typically paragraphs though divs
would be equally suitable).

Each item of data sent to the server is tagged with
information about which control has sent it. This is done
To change the file to which a link refers, in Normal, Tags by naming each control. Thus designers must give a
or Preview mode double-click on the link. The ‘Link
unique name to each control to be used.
properties’ window opens (for an image the ‘Image
The data collected by a form will be sent to a URL
Properties’ window opens - click the Link tab). Edit the
specified in an element ‘action’ which Nvu will add to the
link.
form. This URL is often on the server that hosts the web
To remove the link delete the link reference in the box.
page but does not have to be. The data will be
processed using one of two methods known as ‘GET or
3.7.3

Editing Links
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‘POST’ which also need to be specified. These details
will be available from the provider of the associated
software.
3.9.2 To set up a form
1 Click the form button.
2 In the Form properties window give the form a
name of your choosing.
3 Complete the Action box with the correct URL and
select the appropriate method.
4 ‘Encoding’ and ‘Target Frame’ will frequently not be
required but, if they are, select ‘More Properties’ and
complete the boxes.
5 Click OK
6 On the form place any headings, paragraphs and
images ensuring that there is a placeholder for any
controls needed. (If blank placeholders are needed it
is probably sensible to put some dummy text in now
and delete it later.)
7 Where controls are needed click the corresponding
placeholder and using the drop down box beside the
Form button select the required control.
8 Give each control a unique name.
9 Each control has specific information which needs to
be entered. Enter it into the box in the window which
appears.
Note Since this is a guide to using Nvu and not to
designing forms this is as far as we go.

3.9.3 Form control styles
If the standard form styles do not appeal it is possible by
the use of styles to customise them to personal
preferences. For those familiar with using styles some
specific details are given in section 4.6.2.2.

3.10 Layers
3.10.1 What layers are
One of Nvu’s ‘Tip of the day’ says “Did you know
that … you can move elements? Just place the
caret in the block you’d like to move and click
once on the Layer button to make the block
movable.”
Items forming layers are taken out of the normal
document flow and placed in positions defined on the
page absolutely i.e. in positions fixed relative to the
page boundary.

3.10.2 Creating layers
To create as layer.
1 Click in the block that you want to format as a layer.
2 Click the layer button on the Format (2) toolbar.
The block becomes a ‘Layer’. Layers have sizing boxes
which allow the size to be altered. At the top of the layer
is a positioning handle (denoted by a four-way arrow).
To move the layer click and drag the handle.
Layers do not have to
consist of a single block –
any sequence of elements
that can be selected
together can be converted
into a layer. This may be
several paragraphs with
or without headings,
images and tables.
Layers allow items to be placed on a page so that the
absolute position, relative to the page, is defined. This
provides a facility common in drawing and desk top
publishing programs and allows items to be overlaid on
top of each other. As such it is a very powerful tool.
Text items normally have transparent background so
when overlaid become confused. By formatting them
with a background colour they become solid. Similarly
tables with solid background and non-transparent
images may be overlaid on each other to produce clear
effects.
3.10.3 Characteristics of layers
Items converted to layers have several characteristics
which differ from ‘normal’ items.
Layers in Nvu are contained in ‘div’ elements. (For
more on ‘div’ see section 4.5)
Layers break out of the normal flow in which each
block follows the previous and precedes the next.
Layers have defined width so do not accommodate to
narrowing or widening the viewing window.
Layers do not however have defined height so will
accommodate to changes in text size selected in the
browser.
Layers, as created, are characterised by three
parameters ‘top’, ‘left’, and ‘width’. These define, in
pixels, how far the top left hand corner of the layer is
from the top left hand origin of the page and how wide
the layer is.

Layers may be manipulated using the buttons on the
While layers introduce a level of flexibility to page design
Format (2) toolbar.
they also involve complexities that newcomers may wish
3.10.4 Manipulating layers
to avoid. This section is therefore for those who wish to
delve further.
To move a layer click the positioning handle and drag it
to the required position on the page.
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To resize a layer drag a sizing handle as for other
elements.
When positioning a layer, Nvu allows pixel-accuracy
movement. This can be difficult to achieve and, if it is
attempted to line up items, small errors may become
obvious. Better results may be achieved by snapping
positions to a coarser grid. To do so select Format >
Positioning grid and set the granularity required.
Movement will now be constrained to the selection
made.

3.10.5 Gluing
Six other buttons on the Format (2) toolbar can be used
to modify the behaviour of layers. They are
Glue to the left border
Glue to the right border
Stay in the center
Glue to the top
Glue to the bottom

Note This setting must be set each time a page is
opened. It is not remembered.
Note Snapping applies to dragging the position not the
size.
Warning If several overlapping layers occur on a page
it may become impossible to click on a handle. In this
event try resizing it so that the handles become
accessible, alternatively temporally move another layer
out of the way.
Note If the height of a layer is dragged, though
previously undefined, it becomes defined. However
browsers appear to ignore this.

When positioning layers so that they overlap a
mechanism is needed to define which is in front
(so entirely visible) which behind (so partially
obscured). Two buttons (‘Bring to front’ and ‘Send to
back’) on the Format (2) toolbar take care of this. Select
the layer and click the appropriate button.

Stay in the middle
Clicking the first (Glue to the left) initially has no effect
since this is the default condition. If clicked after some
conflicting condition was set it fixes the distance of the
left hand side of the selected layer from the left edge.
Glue to the right fixes the distance of the right hand side
(rather than the left hand side) of the layer from the right
hand edge.
Glue to the center defines the position, not in absolute
terms but as a percentage of the available width. Thus,
if created at the centre of the space, it will remain in the
centre, similarly for any other ratio.
Glue to the top also represents the default condition otherwise it fixes the distance from the top of the layer to
the top edge.
Glue to the bottom and Stay in the center are best
avoided by other than advanced users who will probably
be using style sheets to achieve the effect required.
3.10.6 Doing it in style

Dragging an item is a rather imprecise action. Nvu
implements layers by using CSS absolute positioning
Layers, as created, do not have a parameter ‘z-index’
styles. More precise control can be obtained by editing
allocated. When brought to the front a z-index with value the style parameters.
=1 is attached. The z-index defines how far forward the
To do so, in HTML tags view, right-click the ‘DIV’ tag for
layer is. If another layer is to be brought to the front of
the layer and select ‘Advanced properties’, ‘Inline style’.
the first it needs z-index to be set to 2. Selecting it and
bringing it to the front however merely sets the index to
It is instructive to note which properties are applied to
1. By repeating the process the index is set to 2 and the achieve each effect.
layer brought further forward.
Gluing option

Note The buttons would be more appropriately labelled
‘Bring forward’, and ‘Send back’.

Initial
Property

Left

Center

Right

Top

Middle Bottom

Values given to property

position absolute absolute absolute absolute absolute absolute absolute
width
px
px
px
px
px
px
px
top
px
px
px
px
px
%
auto
left
px
px
%
auto
px
px
px
right
auto
auto
px
bottom
auto
auto
px

3.10.7 Using classes
Instead of setting up layers manually as described so
far, a class may be allocated to the ‘div’ that contains
the layer. The CSS editor allows classes with the
required properties to be established.
Issued 10-June-2006 based on Nvu version 1.0
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Note Borders can be applied in more than one way. If
you click in a block the border is applied as described.
If, in HTML tags view, you select the block marker the
block is placed in a div and the border is applied to the
div. If, in any view, you select more than one block they
are placed in a div and border applied. (For more on
‘div’ see section 4.5.)

In the CSS editor all the required properties are located
under the ‘Box’ tab. (See section 4.2.1.4) The required
properties and values are
Property Value

Unit

Position

Position

absolute

Width
Top
Left
Right
Bottom

width
Offsets - Top
Offsets - Left
Offsets - Right
Offsets – Bottom

px
px or %
px or %
px or %
px or %

z-index

z-index

Integer

By using a class further options become available which
cannot be achieved by using the toolbar buttons. The
position selector provides options of Absolute, Relative,
Static or Fixed. The ‘fixed’ option is used in the HTML
version of this User Guide to position the menu. The
layer remains in a fixed position on the screen, not
scrolling. The effect is similar to that attainable using
frames for a web site.

3.12 The Body
This is the background on which the whole page sits.
The Body may be thought of as the Page itself. Normally
it is of little concern to the designer but there are a few
situations when it is.
The body can carry a background colour or image which
lies behind everything else on the page in HTML
documents (in XHTML documents, the background
content for the body element defines only the
background for the body element.).Thus the overall
appearance of a page can be significantly determined
by this content.
To set a background
1

In HTML tags view click the body yellow marker
while pressing the control key.

2

On the Status Bar right-click on ‘Body’. (This item is
exceptional in that you will not see it highlighted.)

3.11 Borders

3

Select ‘Inline Styles’ and ‘Background properties’.

Elsewhere a number of methods for applying borders to
images and tables have been mentioned. The level of
control possible has varied from case to case and the
use of style sheets to gain full control has been referred
to.

4

Make the desired selections and click OK.

Warning Internet Explorer version 6 interprets ‘fixed’ as
is it were ‘relative’ so though it displays initially in the
correct position it scrolls instead of remaining fixed on
the page.

There is one further method which is very easy to apply
and which is applicable to all block level elements e.g.
Table (and/or cells), Image, Heading, Paragraph, Form.
The method uses the full border capabilities of CSS
which provides complete control of
Colour of the border
Thickness (width) of the border
Style – Solid, dotted, dashed, double etc.
Different choices for each side
The method does not cover other options which are
sometimes available elsewhere e.g. Padding.
To apply a border select a block and click the ‘
Borders’ button.
Note The Borders button is not installed by default. To
access it customise the Format Toolbar. See section
9.1

Leave the check box ticked and set the style, width and
colour for the top border. If all borders are to be the
same click ‘OK’ otherwise clear the box and edit the
settings for the other sides.
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The ‘Inline Styles’ allows you to set several other
properties for the whole page. This includes Text,
Border and Box properties. This can be a quick way of
styling a whole page since Text properties, for instance,
will trickle down (technically they are ‘inherited’) to
everything on the page for which they are not otherwise
specifically stated. Border and box properties are not
inherited.
Inline styles may set the body width to be less than the
full window width. In this case it may be desired to
centre the page in the window.
To centre a page in the window.
1

In HTML tags view click the body yellow marker
while pressing the control key.

2

On the status bar right-click on ‘Body’ (it will not be
highlighted).

3

Right-click ‘Inline styles’ and select ‘Box properties’.

4

In the ‘Width’ box select the width desired for the
page.

4

In the ‘Margins’ area in both ‘Left’ and ‘Right’ boxes
type ‘auto’.

5

Click OK.
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Stylesheets (see Section 4) often set several general
properties for the body to avoid having to repeat them
several times.

3.13 Table of contents
3.13.1 Introduction
If you have a long document with sections headed using
heading formats Heading 1, Heading 2 etc Nvu can
generate a Table of Contents (ToC) automatically. The
table reflects the structure of the page, the content of
the headings forming the text of the table.
By default the entries in the ToC will be linked to the
heading to which they refer thus facilitating navigation
around the page.

5 If, instead of using headings you wish to use classed
paragraphs or a div, instead of selecting a heading
tag select ‘p’ or ‘div’ and in the box in the column
headed ‘Class’ enter the class required. (It is, of
course, also possible to select headings by allocating
a class.)
6 If you wish the contents to be numbered check the
box ‘Number all entries ...’.
7 If you wish to build a ToC only but not have it link to
the listed tags check the box ‘Make the table of
contents read-only’.
Warning In Nvu 1.0 this option appears to be disabled.

8 Click OK.

If required, the ToC can be numbered so that the
Heading 1 levels are numbered from 1 upwards,
Heading 2 levels are numbered from 1 upwards but this
numbering restarts each time the level 1 number is
incremented. Similarly for lower levels.

The Table of Contents will be created.

It is not necessary to list all heading levels in the ToC;
for example it is possible to select only first and second
levels. More importantly it is not necessary for the page
to include any particular heading level so, if the page
formatting uses Heading 5 and Heading 6 only, these
may form the basis of the ToC; thus the use of Table of
Contents imposes little restraint on the document
structure.

1 Click Insert > Table of Contents > Update.

If the headings in the page do not provide a satisfactory
structure for the ToC it is possible to include short
paragraphs specifically for this purpose. These may be
included at any level in the ToC. The selected
paragraphs are identified by applying a named class
style (section 4.2.3) generated for the purpose (unless
fortuitously pre-existing). Alternatively a <div> (section
4.5) to which a named class style has been applied may
be used.

There is no need to place the cursor.

Generating and using a ToC in this way has the
considerable advantage that it can be automatically
maintained ensuring that changes to the page are
accurately reflected.
A ToC works only within the page in which it resides.
Links to other pages must be entered and maintained
manually.
3.13.2 Inserting a Table of Contents

To update a ToC after changes have been made to a
page.
There is no need to place the cursor.

2 The ‘Table of Contents’ window appears showing the
selections previously made.
3 If desired, changes may be made to the selections.
4 To update the ToC click OK.
To delete a ToC.

1 Click Insert > Table of Contents > Delete.
3.13.3 Methods
Nvu builds the ToC using Ordered or Unordered lists.
(section 3.4.4). These lists have to be nested to produce
the structure required. The result is that each level of the
contents is indented relative to the previous. The
indentation may be altered using styles and specifying
the OL or UL and LI elements. The changes required
will be to the margin and padding (section 4.2.1.4). Any
changes made will apply to all lists on the page (not only
ToC).
In order to make links work, each tag listed in the table
will have a named anchor added automatically when the
table is created or updated. Deleting a ToC also deletes
all these anchors.

To insert a ToC

3.14 The Head area

1 Place the cursor where the table is required.

Every HTML document starts with a “Head” area. This
provides information to browsers, search engines etc
but is invisible on the page.

2 Click Insert > Table of Contents > Insert.
3 The ‘Table of Contents’ window appears.
4 In the column headed ‘Tag’ select the tag for each
level e.g. against level 1 select h3 and against level 2
select h4 and for all the others select ‘--’.
Issued 10-June-2006 based on Nvu version 1.0

Items included on the head are gathered from a number
of sources. These may include:
Items dependent on the Doctype as set when
creating the page (section 3.2.1).
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Items collected from Page Preferences (section
9.2.3). Includes Author, Language.
Items set by the Format > Page Title and
properties menu. Includes Title, Author,
Description, Language, Writing direction
Character set.
Links to stylesheets (section 4.1.3.3)
Definitions for internal styles (section 4.1.3.2)
Source view allows advanced users to add further
information as desired.

3.15 Page views
Nvu provides four ways of viewing a page – ‘Normal’,
'HTML Tags', 'Source', 'Preview'. These are selected
using the tabs on the Edit mode Toolbar. All provide full
editing facilities.

Preview mode offers almost the same view as in a
browser with the addition of rulers and sizing boxes.
The main differences are that scripts do not run (so
their effects will not be seen), links do not operate
and the style for links does not respond to any class
set. Tooltips do work however.
Normal view is very similar but here table outlines
show and markers for named anchors appear.

“Span” is used when certain changes are made inline
with text – for instance if the colour is changed for a
single word. Span in HTML has a more restricted use
being confined to changes implemented using styles.
This may be confusing.

In HTML Tags view background images do not appear.
q Source view shows all detail of the HTML code. All
except the DOCTYPE may be edited.
An additional view is provided via the ‘Browse’
button. This opens your default browser and gives
full browser functionality and display to a page.
Warning If your default browser is Internet Explorer the
page may open in source view instead of page view.

3.16 Editing in Source view
This mode is intended for those confident in coding in
HTML. In this mode Nvu is not simply a text editor. On
switching to a different mode Nvu carries out checks to
ensure that the code is valid. If not it ‘fixes’ it. It will have
made its best guess at what was intended – if it gets it
wrong there is no going back – no ‘Undo’ button. While
this may sometimes save you a lot of typing, if you know
what you are doing, it is also possible to end up with a
heavily ‘messed up’ page – it will display but half the
content could have disappeared.
Needless to say good backup practice can save many
disasters. The Site Manager (Section 8) is actually a
convenient tool for doing this. Create a backup folder
and ‘Publish’ to this !
The line numbers which appear are an editing
convenience, they form no part of the code. They can
help to find your place when switching modes. When
switching between applications the numbers are only an
approximate guide.
Nvu provides some options in how lines are displayed
as mentioned in Section 9.2.4 on ‘Preferences’ or see
Nvu Help.

HTML Tags view assists those familiar with HTML.
There is a yellow marker for the start tag for all
elements (end tags are omitted). Clicking on a marker 3.17 Selecting items - Reprise
selects and highlights the whole of the element.
By now Nvu users should be familiar with selecting and
manipulating items. A recapitulation may be useful
Note If clicking an element does not select it press the
however.
control key while clicking.
You will also see the element highlighted on the Status
Bar (see figure). If you switch to Source view the
element remains highlighted,
Note It will be on the screen but possibly right at the
bottom.

This is of great assistance in editing. Marker names
correspond with the HTML tag name with a few
exceptions.

These comments apply in Normal, HTML Tags or
preview mode.
Nvu often offers a number of ways of doing something.
Sometimes one method will apply sometimes an other.
Which works will depend on a) what is to be selected
and b) what is to be done with the selection.

Note Named anchors are shown with a symbol
whereas linked anchors are denoted by 'A', The marker
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Selecting text
Simply place the cursor anywhere in a block. This is
often sufficient where a format is to be applied to a
complete block.
Double-click within a block to select a word.
Triple click within a block to select a line of text.
Drag across a section of text to highlight and select
that section only.
Many functions may be carried out on the selected text
this includes

Selecting via the Status bar
This is a quite excellent tool. Click in any text object or
image, then, on the Status bar, click on the element
marker farthest to the right. The object is selected. To
the left of this are shown any elements higher in the
document tree. Click any of these to select the
corresponding elements.
Double clicking
This provides a powerful context-sensitive function
which often provides the fastest route to appropriate
actions.

Applying a class

Double click an image to reach the 'Image properties'
window which allows changes to image location,
name, size, link etc.

Changing the element tag e.g. changing from a
paragraph to a list.

Double click a link or anchor to edit the name,
properties etc.

Dragging to a different position,

Selecting in HTML tags view
Sometimes selections in normal or preview mode
become difficult or impossible.
In HTML Tags view press the Control key while
clicking on the tag for the block to select a complete
block.
Actions appropriate to complete blocks such as
dragging or applying a class are possible.

Issued 10-June-2006 based on Nvu version 1.0

Double click a table or cell to access properties such
as size, colour, alignment.
Double click most things to obtain access to
'Advanced properties' via the 'Advanced edit' button
which appears on the first window to open. While
these require more detailed knowledge of HTML or
CSS they can be used to apply extensive formatting
options to items.
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4 Style and stylesheets
4.1

Introduction to style

The use of styles is already well established in word
processing and desk top publishing. In web site design it
assumes an even more important role and can control
almost every aspect of presentation.
Styles in HTML documents should comply with the
requirements of the W3C style specifications. These are
detailed in ‘Cascading Style Sheets, level 2 CSS2
Specification’ which is available at
http://www.w3.org/TR/REC-CSS21.
A full introduction and many useful references may be
found at
http://en.wikipedia.org/wiki/Cascading_Style_Sheets
4.1.1

Power of styles

Styles specify how particular elements on a page
appear on the screen, in print or whatever. This guide
limits itself to on-screen considerations. By ‘elements’
we mean parts of the page structure, typically headings
and paragraphs, but also stretching to many others
including tables, bulleted and numbered lists etc. In fact
most HTML ‘Tags’ may be specified though the same
style may be applied to several.
Style may typically define such aspects of presentation
as the font face, size and variant, the font colour, the
background colour, whether an element is to be aligned
right, centre or left, whether spaced away from other
elements, surrounded by a box and, if so, what type or
colour. Elements may be given an absolute position
relative to the page (which allows elements to overlap).
Elements such as paragraphs, tables and images are
considered to exist within boxes or blocks and the sizes
of these boxes may be specified.
Note You can see the outlines of the blocks by
selecting ‘View - Block outline’.

4.1.3

Using style

4.1.3.1 Inline style
Within a page styles may be used in three ways. These
ways can be mixed and matched as you wish. The first,
easiest and crudest is to define a style for the nonce,
there and then. Such a style is listed in the code (in
Source view) with the tag to which it applies (using the
structure “style = …” if you look at the code).
Don’t worry Nvu hides all this from you.

If you have an other item with the same style this code
must be repeated. This bloats the page. This is known
as an ‘inline style’. For the most part Nvu users do not
have to be concerned with this method although Nvu will
sometimes use it without you knowing.
4.1.3.2 Internal style
The second way to use a style is to embed a list of style
definitions within the HEAD section of a page. (These
definitions are referred to as ‘style rules’ or just ‘rules’.)
These rules may be of one of two sorts. The first sort
applies to all elements of a particular type (e.g. p, h1,
table) the second is the class as discussed above.
Note If you look at the HTML source code you will see
a structure like <p class="mynicepara”> when the
class “mynicepara” has been applied. The
corresponding code where no class is applied is <p>. If
you look at the structure of the style sheet for a class
you will see the class name preceded by a dot (full
stop) e.g. “.mynicepara” while a generally applied
style will look like 'p'. Generally applied styles must, of
course, carry the name of the element to which they
apply whereas a class can have any name you like to
give it. To help maintain the site it is good to give it a
name that describes its function NOT the resulting
appearance.

4.1.3.3 External style – Linked stylesheets
While the first two methods are valid and have their
As well as allowing you to specify the style of elements it uses, the third is the preferred method specifically
is possible to define styles and apply them selectively to because it is economical, reuses the same styles for
only some elements. This is done through ‘Classes’ – a many pages and helps in achieving consistency of
appearance right across a complete web site. The
‘Class’ is just a style that can be applied as and when
method uses an external style sheet which is ‘Linked’ to
you choose.
a page, or to several pages (though each page must
‘Classes’ are applied to ‘Tags’ (a marker attached to an
include the linking information for itself).
element). The element to which the class is applied
appears in the format defined by the class. Other similar An external style sheet contains the same list of
elements without the class applied appear in the default definitions which would otherwise have been included in
the internal list referred to above. (It is actually a simple
format i.e. either the default specified by the browser or
the style that the user has defined for the corresponding text document such as you could construct using a text
editor like Windows Notepad.) The file is usually located
element.
in the same folder (directory) as the page to which it is
4.1.2

Classes
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linked (though it can be elsewhere) and has the
extension ‘css’.

When internal styles are created Nvu will include the the
rules for these in the 'head' area of the document.

How does a page know to use this style sheet? A line of
code which, Nvu will insert for you in the head section of
your page, will see to this.

To start creating styles:

The code looks like <link rel="stylesheet"
type="text/css" href="mystylesheet.css">

1 Open Tools > CSS Editor.
2 Click 'Style elt', ‘Create Stylesheet’.
3 Click RULE.

Warning This is one of the few places where Nvu 1.0
makes a mess of things. It inserts an absolute
reference instead of a relative reference. This will work
fine as long as your pages remain on your own
computer but, if you move them to a new folder or
upload them you will need to edit this line manually.
See Section 4.2.4.1

4 The General tab opens and offers the options
‘Named Style’ or ‘Style applied to all elements of
type’ or ‘Style applied to all elements matching the
following selector’.

4.1.3.4 Cascading style sheets
You may wonder – if you have an external style sheet,
perhaps internal style rules and inline styles will there be
confusion? This is where the cascading comes in. Your
browser should first use whatever its default style would
be. If it finds a matching style in an external sheet it
should use that instead, it should then look at internal
styles and, if any coincide with anything it is planning to
use that should override them. Lastly inline styles
prevail.

6 In the box type “p”, or the tag for the element e.g.
“h1” (without the quotes).

How could that be used? Well perhaps your site
establishes a style using an external style sheet.
Perhaps you have one page about emergency
procedures and you decide that all its paragraphs
should be in red. You simply add an internal style on
that page redefining the ‘p’ tag to be red but also link the
page to your normal style sheet. All your normal styles
will be applied except that all paragraph text will be in
red, nothing else will be non-standard.
Nvu will actually allow you to link several external sheets
to a page. The CSS specification sets up rules for
prioritising these in the event of a style being defined on
more that one sheet. Some browsers do not respect the
rules. Consequentially both the browsers and designer
are likely to become confused. Take great care before
adopting this practice.
Perhaps in an attempt to assist here Nvu allows you to
switch off style sheets while testing pages. With the
CSS editor open (see later) select a stylesheet and
check the ‘Disabled’ box.

4.2
4.2.1

Creating styles
Internal styles

To style an element e.g. a paragraph:
5 Select ‘Style applied to all elements of type’.

7 Click ‘Create style rule’.
In the pane on the left you should see a structure
showing each tag as it is defined.
To define how you want elements to look:
1 Click the tag for the element in the left hand pane.
The General tab should show, listing the ‘Selector’
(at present the element tag) and any style
‘Declarations’ (initially blank).
2 Now select in turn as required the tabs for ‘Text’,
‘Background’, ‘Border’ etc and specify exactly how
you wish that element to appear. The next section
amplifies some details of how to do this.
3 Return to the general tab to see the full declarations
that you have set for the Selector.
I won’t go through all the options, just mention a few.
First, do note you are not obliged to specify any
particular properties. You specify as much or as little as
you wish. It’s just that the browser will revert to defaults
if you don’t. There are fairly complicated rules for what it
uses, and browsers don’t always follow the rules,
however chances are that you’ll be happy with whatever
it does – if you’re not – change it!
You may like to try setting rules for the ‘body’ and apply
it to all elements. In most cases rules specified here with
trickle down to everything else (they are ‘inherited’)
unless you specify it explicitly elsewhere. Generally this
works but can generate surprises.

Styles are created and edited using the built in Style
sheet editor called CaScadeS. CaScadeS has two
modes of operation ‘Beginner Mode’ and ‘Expert Mode’.
When it opens it opens in expert mode, should you wish
to switch to Beginner Mode clear the check box. The
difference is that in Beginner mode External style sheets
cannot be created.
Issued 10-June-2006 based on Nvu version 1.0
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Style Nomenclature
Styles employ a bespoke nomenclature. Nvu uses this little since, except in source view, the code is hidden
from the author. The terms involved do appear in this User Guide. Here they are along with some
examples. The examples show the source code that would appear either in the head area of your page or in
an external style sheet.
Simple rule

p { font-family : Arial , sans-serif ; }

Rule with 2 declarations

p { font-family : Arial , sans-serif ; font-size : medium ;}

Rule with 2 selectors

h1 , h2 { color : #990000 ; }

Rule with class selector

.redtext { color : red ; }

Complex selector *

#menu li a:link { text-decoration : none ; }

Key:
Rules appear within a blue bordered box
Declarations have a dashed border
Selectors have a red border and white background
Properties have a green border and white background
Values have an magenta border and white background
* This selector selects list items in the menu div which are linked.
4.2.1.1 Text Tab
Font family. You are offered three ways of specifying
q Unspecified
q Pre-defined
q Use custom font family
In common parlance ‘font families’ are referred to as
‘fonts’. CSS always refers to them as ‘font families’. The
correct typographic term is ‘Typeface’. (The English
word for ‘font’ is “fount” but sadly the American word
has come into general use in the UK.)

‘Unspecified’ leaves everything to the browser
‘Predefined’ has a drop down selector offering one of
three choices. Each choice has a set of 3 fonts which
have fundamentally similar characteristics. The choices
are:
Sans serif proportional fonts.
Serif proportional fonts.
Fixed spacing fonts.
Each set has three entries. The first two are alternative
similar fonts; the third entry is a statement of the generic
font type – the browser should look for the first font
Issued 10-June-2006 based on Nvu version 1.0

listed, if it can’t find it, look for the second and, if that
can’t be found, use a font of the generic type of the final
entry. Thus something suitable will always be found.
See Warning below when using this option.
‘Custom font family’ is an option to be avoided or used
with extreme caution. The list offered is taken from the
fonts installed on the author’s computer. If you choose
one which is not available on your visitor’s computer
there is no control over what will be used.
On the other hand, if carefully used, this option is very
flexible and you can build your own set using the model
from the ‘Predefined’ selector.
To build a set of fonts.
1 Note the structure of the ‘Predefined’ sets. The lists
are built with each font name terminated by a comma
and each set finished with a generic type.
2 Select a generic type from the following: serif, sansserif, cursive, fantasy, monospace.
3 Select preferred fonts corresponding to the generic
type required.
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4 With the Text tab selected check ‘Use custom font
table which sits within a division. One of the tables and
family’ and in the box type the name of your
one of the cells has font size specified. Others do not.
preferred fonts each followed by a comma, finish with
Text in division.
a generic type.
Size not specified – Inherited
Note 1 You will probably wish to include one font
available on Windows PC systems and an equivalent
available on Macintosh computers.

Text in Table. Size not specified – Inherited
from div

Note 2 You may enter as many fonts as you wish.
Note 3 Using ‘cursive’ or ‘fantasy’ options is not
recommended since the level of standardisation
between visitors will render the results very uncertain.
Note 4 If you use a font which has a name which
includes spaces (such as Times New Roman) the
name must be surrounded by quotes e.g. "Times New
Roman". If you fail to do this the result will probably still
work but validation will fail.
Warning Unfortunately when Nvu builds sets of fonts
itself it fails to do this. The fixed spacing option
presents no problem but the two proportional options
use fonts with spaces in the font names. Authors must
either suffer the indignity of failing validation or edit the
style values in source view to overcome the problem.

Font size. There are three sections offering different
types of option. The first block is a miscellany offering
various units. Because display screens vary in size and
resolution and because people’s eyes and preferences
differ, browsers offer ‘View’ options allowing the user to
alter the text size. If this facility is disabled the user may
not be able to see the page as he or she would wish.
Some of the options in this first group (e.g. px, pt, cm in,
mm, pc) either apply to print media or are for fixed size
units. These may disable browser zooming or result in
unpredictable sizes. You will probably find the last set of
named styles (starting xx-small) is most satisfactory,
alternatively use the percentage or em scales. As you
select and alter the size you can see the result directly
on your page.
Absolute and relative sizes.
When setting font sizes for text lying directly in the body
element 1em, 100% and 'medium' generally yield
identical results. Font sizes are inherited so text in
elements which themselves sit in the body will, unless
specified separately, use the same sizes. Elements may
however sit, not directly in the body but, within other
elements such as a table or a division. Where such a
table or division has a font size set on iteslf this may be
inherited to text within that table or division. For
instance, if a div has font size set to 150% and a
paragraph within the div has font size set to 1em then
the text will actually be rendered at 1.5em due to it
inheriting the scale from the div.
Note A division is formed using the <div> element. See
section 4.5

An example of how this can work is given in the
following figure. Text sits in table cells, which sit within a
Issued 10-June-2006 based on Nvu version 1.0

Size for this cell set to 120%
Text in second table.
Text size for this table set to 120%
Size for cell not specified – Inherited
from table
Not all sizes scale in this way. Sizes set as a percentage
or in em or ex do scale and are referred to as relative
sizes. Sizes specified using the xx-small system do not
scale and are referred to as absolute sizes
Note All sizes will zoom using the browser text size
options with the exception of sizes specified in pixels. In
this case browsers vary in response.

Font Colour. Either enter a colour into the box or click
on the button to the right. If you click on the button the
‘Text Color’ window opens and you have three more
options. (It’s like buying an ice cream in the USA or
making a phone call in the UK.) You can specify in
terms of Hue, Saturation and Brightness (HSB), Red,
Green Blue values (RGB) (range 0 to 255). Alternatively
click on one of the 70 boxes of colours offered.
These are so-called “web safe” colours because they
work on lower performance displays. Actually the full
range of 216 web-safe colours is not provided but, in
any case, modern displays normally work in at least
24-bit colour so there is little justification for this
limitation.

The next option is to click on the rainbow type area.
Whichever you choose, the selected colour appears
immediately on the square. Fine adjustments may be
made using the RGB or HSB values. A box labelled Hex
value shows the colour as a hexadecimal number.
Actually you could have done this directly without
opening the ‘Text Color’ window – when you close the
window you’ll see the hex value (preceded by a ‘#’) in
the box along with a sample of the colour on the button.
Named colours. You’re welcome to skip this note
but there is one other method! You might have
noticed, as you clicked on one of the 70 colours,
that occasionally in the box labelled ‘Name’ the
name of a colour appeared. (Try black or red to
check.) The CSS recommendation recognises 17
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colours and the names of these can be entered
directly here, or, in fact, into the selector box
without entering the ‘Text Color’ window. The valid
names are “aqua, black, blue, fuchsia, gray, green,
lime, maroon, navy, olive, orange, purple, red, silver,
teal, white, and yellow”.

Other text options

the edge of the enclosing block). Other elements may
therefore appear to wrap around them.
Position, Offset and z-index are parameters related to
the use of layers. These have been covered in section
3.10.6
4.2.2

Styling multiple elements

These appear below the colour option and are fairly self- Instead of setting styles for one element at a time it may
be easier to specify several at the same time. Perhaps
explanatory.
all your headings are in one font (e.g. serif) and all
4.2.1.2 Background Tab
others in an other (sans-serif). You can specify h1, h2,
h3, h4, h5 and h6 as serif font in a single action by
Colour
listing them and separating by commas after selecting
This is selected in the same way as for Font colour.
RULE, “Style applied to …” . Later you can specify, for
example the size of, each heading individually in a
Image
separate rule.
You can specify an image file as a background. This will
Note If you style multiple classes you must precede all
appear behind anything else. Under ‘Tile’, if you select
but the first by a dot e.g. style1, .style2
‘Don’t tile’ you get a single copy of the file which you can
position with the buttons below. If you select ‘Tile’ the
4.2.3 Named Classes
image repeats in the directions selected.
I’ve suggested above that you start by applying styles to
all elements of a specific type. Such style definitions will
Warning. The opacity option uses a property not
included in the CSS2 Specification, which is either not
apply automatically wherever that element is found on a
implemented or implemented incorrectly by most
page. This provides for great consistency within a
browsers.
document but maybe a touch of dullness! You can also
define your own styles and apply them selectively.
4.2.1.3 Border
These styles are known as ‘Classes’.
Items can be bordered and the options available provide
To create a class
great flexibility. Styles, thickness and colours may be
set independently for each side.
1 Open the CSS Editor, and if necessary create a style
Note For a border to show both width and style must be
specified.

4.2.1.4 Box
The block structure in which most elements are located
has already been mentioned (section 3.4.1). The Box
options control the display within these blocks.
For those boxes which require a dimension to be
entered: first type the number, then select the unit from
the drop down box.
Margin Controls the distance between the element’s
box, i.e. where any border would be, and either the
surrounding box or adjacent boxes.
Note Vertical margins ‘collapse’. If a heading has a
bottom margin set to 20px and is followed by a
paragraph with a top margin set to 10px the separation
between them is controlled by the greater (20px) not
the sum (30 px).

sheet, as described in section 4.2.1
2 Click on the stylesheet to select it. (If there is more
than one stylesheet click on the one in which you
wish to create the class.)
3 Decide on a name for the class.
Note Class names can contain letters, numbers and
underscores but not spaces and must not start with a
number. They are case insensitive.

4 Click on RULE, leave ‘Named style’ selected and
enter your chosen class name in the box.
5 Click on ‘Create style rule’. You should see the name
of your style appear in the pane on the left but note
that the name is preceded by a dot (full stop).

Now proceed as in section 4.2.1 ‘To define how you
want elements to look’. In that case you could watch
the effect of your styles appear immediately on your
page (assuming that you had a page which used the
Padding Controls the distance between the box content
corresponding elements). Now, of course, you have
and its border.
none, so first we must learn how to apply a class to an
Width and height Allow a specific size to be allocated to element.
the content area of a box. This can be an absolute width
First enter some details for your new class that will allow
or a percentage of the containing box.
you to recognise it on the screen if it is applied. For
Float allows blocks to be treated rather like images and instance use the border tab to produce a border styled
to float them to the right or left hand side of a page (or to as solid, 2px wide, coloured red.
Issued 10-June-2006 based on Nvu version 1.0
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It is possible to set styles for several classes at the
same time just as it was for elements. Proceed as in
4.2.2 but, in this case, you must precede all but the first
by a dot e.g. style1, .style2 (Nvu automatically
adds the dot for the first).
4.2.3.1 Applying Classes
Nvu provides two methods for applying classes. Method
1 is the simpler; sometimes it is difficult to select the
item to use this method in which case method 2 is
preferable.
Apply a class - Method 1
1 If necessary close the CSS editor.

4 Right click on this (on the toolbar) and select
‘Classes’. You should see a list of all classes pop up
(This includes classes on internal and linked
stylesheets.) Any class already applied to the
element appears, marked with a tick, at the top of the
list above the divider line; other available classes are
below the line.
5 To add a new class, click the class;
To remove a class, click the class above the divider.
Note Elements can actually have several classes
applied. If you do this you should ensure that the class
properties don’t conflict with each other. Most people
will probably prefer to apply only one class at a time.
You may need to check that you don’t apply more by
mistake.

2 Select the item to which the class is to be applied.
For a heading or paragraph simply click in the text, to
4.2.3.2 Removing classes
apply a class to an inline section of text (span)
A similar procedure may be used to disconnect an
highlight the text.
element from a class. Using the highlighted tag method
3 Use the class selector box on the Format toolbar
simply select the ticked class, this deselects it. Using
(see figure), click the drop down arrow and select the the class selector box select the style again, this should
class required.
cancel it. Alternatively, after selecting the element, rightclick on the highlighted tag on the status bar and select
‘Advanced properties. The selected class will be listed
select it and click ‘Remove’.
4.2.4

External styles

There are three ways to start working with external style
sheets
4.2.4.1 Create a new external style sheet
External style sheets are created in almost exactly the
same way as internal sheets.
To create an external style sheet
1 Open the CSS Editor. (Tools > CSS Editor).
4 The result of applying the class should be seen in
any view mode.
Note Although Nvu is not a browser it replicates the
browser display very well. However styles applied to
links are not rendered correctly at present.

Apply a class - Method 2
Note This mode cannot be used to style an inline
section of text (using span).

1 If necessary close the CSS editor.
2 EITHER in 'HTML Tags' view Click on the yellow
marker for the element for which you want to set a
class. (If the element does not become selected, as
indicated by outlining or highlighting on the screen,
press the control key while selecting.)
OR in Normal or Preview mode click in a block you
wish to style then click on the Status bar on the rightmost element listed.
3 Now both the block involved and the corresponding
element and on the status bar should be highlighted.
(See figure above.)
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2 Make sure that you are in ‘Expert Mode’ and Click
‘Style elt.’
3 Type a title in the box and click ‘Create Stylesheet’.
4 Click ‘Export Stylesheet …’ Give it a name with
extension css and save it, preferably in the same
folder as your page.
Now click on ‘RULE’ and you should be on familiar
territory.
When we created internal styles they were entered on
our page in the HEAD section. Now the styles are being
created in an external file. If you looked, in ‘Source’
View, in the head area you would see a line referring to
the external file and linking it to your page.
Warning Unfortunately, at the moment, Nvu makes a
meal of inserting the filename. It puts the absolute
address of the file as it appears on your hard drive.
When you upload or move your page the stylesheet
won’t be found. You will need to edit the HTML Source
code in the line starting <link rel="stylesheet"
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(note the ‘line’, which may spread over several lines,
finishes type="text/css">) Delete all the code like
file:///C:/Documents%20… right up to and
including the / before the filename. The result should
contain text like href="filename.css". If your
stylesheet is in a sub-folder the text should be like
href="subfolder/filename.css".

4.2.4.2

Change an internal style listing into an
external stylesheet
If you already have set up your page using internal
styles you can convert them into an external stylesheet
and link to that.
Open the CSS Editor. In the ‘Sheets and rules’ pane
click on the stylesheet and under the general tab click
on ‘Export stylesheet and switch to exported version’
and proceed.
4.2.4.3 Link to an existing stylesheet
If you have a stylesheet that you created for another
page or intend to use right across your site you can link
your page to that.
To link to an existing external style sheet
1 Open the CSS Editor. (Tools > CSS Editor).
2 Make sure that you are in ‘Expert Mode’ and Click
‘Link elt.’
3 Click ‘Choose file’ and browse to the location of the
stylesheet you want to use.
4 Click 'Open' then ‘Create stylesheet’. You should
then see the stylesheet name appear in the ‘Sheets
and Rules’ pane to the left.
You can now close the CSS editor, but, of course you
can work on the stylesheet in the usual way.
NB the same warning applies as in section 4.2.4.1

In addition to these the CSS specification provides a
large range of more complex selectors most of which lie
outside the scope of this Guide. For details see the CSS
Specification section 5. (See appendix 2.) There are
however a few cases which are needed more frequently
and for less complex sites and these are covered in the
next two sections.
4.2.5.2 Link styles
Browsers render links in default colours and Nvu
provides some options for controlling these (see
3.7.1.6). Through the use of styles full control of each
state of a link is possible. This is achieved through the
use of selectors called link ‘pseudo-classes’.
The more important pseudo-classes are
a:link
for all links not yet visited
a:visited for links that have been visited
a:hover
for a link over which the cursor is hovering
Note The following procedures are based on the use of
internal style sheets. Very similar procedures may be
used with external stylesheets.

To create link pseudo-classes
1 Proceed as if creating a class (see section 4.2.3)
2 At step 4 select ‘Style applied to all elements
matching the following selector’ and in the box enter
the selector as listed above.
3 At step 5 the selector name should appear as
entered.
It is now possible to style these options fully, i.e. not only
with text colour and decoration but with background,
boxes, the lot.
Note that the a:hover must be placed after the
a:link and a:visited rules, since otherwise the
cascading rules will hide the a:hover rule.

4.2.4.4 Saving stylesheets
Once you have linked and saved a stylesheet, if
changes are made later, the changes will appear in your
document immediately and the sheet will be re-saved
when the page is saved.

The CaScadeS CSS editor enters styles in the order
encountered. The order may be altered by selecting an
item and clicking the ‘Up’ or ‘Down’ button.

Warning If the sheet is linked to several pages, any
others which are open in Nvu at the time will not
recognise the change until they have been closed and
re-opened.

Note These styles will now be applied to links
automatically. They do not have to be applied manually
as do classes.

4.2.5 Other style selectors
4.2.5.1 Introduction
Element styles (section 4.2.1) and named classes
(section 4.2.3) are the two main ‘selectors’ used for
styles. A selector may be thought of as the link which
attaches a particular style declaration to a particular item
on a page.

Warning in Nvu 1.0 the ‘Down’ button is disabled.

4.2.5.3 Form control styles
Setting up forms to appear as required may require
styles to be set for specific controls. These are set
exactly as just described for links it is merely necessary
to set styles for the required selectors. Some of the main
ones are listed following.

Note Strictly the class selector consists of the class
name and a prefixed dot.
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Control

Element

Selector

Submit button
Reset button
Text input
Text area
Label
Field set
Legend

Input
Input
Input
textarea
label
fieldset
legend

input[type=submit]
input[type=reset]
input[type=text]
textarea
label
fieldset
legend

4.2.5.4 ID styles
Ids (or Unique identifiers) haven’t been mentioned so far
and I won’t explain fully. They can be used for several
purposes though support in Nvu at present is limited.
Since an id is a unique identifier it can be used once
only (on any page). Most commonly ids are used in
conjunction with the div element to mark a particular
area on a page such as a table of contents, a menu or
some such. It is helpful in such cases to give the id a
name which indicates its use.
To create a style based on an ID
1 Select a name for the id. This must follow the same
rules as for a class. See section 4.2.3.
2 Proceed as if creating a stylesheet and styling an
element (see section 4.2.1).
3 At step 6 enter the name of the ID preceded by the
number sign e.g. #menu.
To apply an ID
While, in principle, ids are similar to classes it is not
possible in Nvu to apply an id via the class selector box
but the method is still easy.
1 If necessary close the CSS editor.
2 Click in the div to which you wish to apply the id.
3 On the status bar click the <div> tag. If there are
more than one, select that furthest to the right. Both
the tag and the content of the div should be
highlighted.
4 Without moving the cursor right-click and select 'id'.
5 From the pop-up list select and click the id required.

4.3

Removing styles

The CSS editor allows you to remove styles in a similar
way to adding them.
In the ‘Sheets and rules’ pane select the rule you want
to remove and click ‘Remove’.
Similarly you can remove a stylesheet. Select the sheet
and click ‘Remove’. If you select an internal stylesheet it
is deleted from the file completely.

Issued 10-June-2006 based on Nvu version 1.0

Warning this deletion is not reversible using ‘Undo’.

If you remove an external stylesheet the link on the
page is removed irreversibly but the external file is left
intact.

4.4

Inheritance

A web page has a hierarchical structure e.g. text in a
table cell sits under the ‘Table’. You see some of this
structure in ‘HTML Tags view’.
Inheritance means is that style properties set at a high
level in the structure e.g. at ‘Body’ level will be applied at
lower levels unless specifically re-specified. So a font
family set the ‘Table’ element will be applied to
everything in the table but if you include a paragraph in
the table and set a different font for the ‘p’ element then
that will be applied. Section 4.2.1.1 has already shown a
small demonstration of the effect.
Inheritance is very useful as it allows properties to be
set once in a style sheet rather than having to be
applied to every element that you want to use that
property.
You will have to consult a detailed specification (such as
appendix F ‘Full property table’ of the CSS2.1
specification) to see what is inherited and what is not
but, in general, you can assume that all properties are
inherited except things like Background, Border, Margin,
Padding, Width and positioning.

4.5 The <div> element
The <div> element has been mentioned only in passing
so far. A div establishes a ‘division’, i.e. a section of a
page, to contain a number of elements. Within a div
styles are often applied in particular ways as will be
touched on later. The remainder of this section is not
intended as a full explanation of what a div is or how to
use it rather it is an explanation of how to create and
populate a div using Nvu. Other aspects of divs are
likely to be beyond the interest of beginners.
4.5.1 Creating divs
To create a div
1 Place the cursor where the div is to be created.
Note Do not try to create a div as the last item on a
page unless you do not need to add items after it.
Note It may be easier to see what is happening in
HTML tags view with View > Block outline selected.

2 Click the first drop-down box on the format toolbar.
3 Click the last option at the bottom of the list - Generic
container (div).
4 The div is created formatted as body text.
It is now possible to insert any desired item into the div
e.g. Text or images. Text may then be selected and
formatted as paragraphs etc. If required, divs may be
inserted so that a set of nested divs is produced.
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Sometimes difficulty may be experienced such that
elements in a div disappear when an attempt is made to
populate them. To avoid this, it is undesirable to insert
empty elements, so either insert, for example, one
paragraph at a time or enter some dummy text as a
placeholder.
To apply a class to a div
Proceed in the normal way (see section 4.2.3.1). The
class selector box may be used to apply a class to a div
but it will not display the class which has been set. The
preferred method to use is via the highlighted tag on the
status bar which can be used to add or remove classes.
To inspect or change a class
Use the status bar to access the class.
Elements within a div may have styles applied in the all
the normal ways.
To leave a div
Click in any area outside the div. This is why a div
should never be the last item on a page it will be
impossible to leave it except to visit an item higher on
the page.
Unique divisions
A common use of divs is for unique regions of a page.
Examples might be a menu, a table of contents or the
main text area. In such cases rather than applying a
class to a div it is more appropriate to use an 'id'. (See
section 4.2.5.4.)
4.5.2 Styles within a div
A div is a useful way of applying a different set of styles
within a limited region on a page. Of course a set of
classes could be designed and applied to the elements
within the region but this is laborious and bloats the
code. A simpler way is to set up a set of styles for the
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elements in the div and to tag them in such a way that
they apply only within the div. This is done using an
appropriate selector. Suppose the div has a class
‘divclas’. Examples of appropriate selectors are:
div.divclas p
div.divclas td
div.divclas a:visited
Or when using ids:
#menu p
#content li
These may be set up in the same way as for pseudoclasses see section 4.2.5.2.
4.5.3 Creating a layer using a div
In section 3.10.3 we noted that ‘Layers’ are contained in
‘divs’. In fact a Layer is simply a div which has a
position, and optionally a z-index, style attached. When
Nvu creates a layer it does so by attaching an inline
style to the div.
It is equally possible to create a layer by setting up an
appropriate class and attaching this to a div.
When a layer is created in this way Nvu depicts it as a
normal layer and renders it with a surrounding box with
sizing and position handles. Visually it is
indistinguishable from any other layer.
Such layers may, of course be precisely located and are
not subject to the vagaries of manual dragging.
Warning If a layer, created using a class, is
subsequently dragged or resized, Nvu attaches an
inline style. Any styling so added will override the class
styling.
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5 Scripts
Scripts are short programs that are included in HTML
documents (and therefore consist of alphanumeric
characters) which run on the browser and can change
the presentation of pages on some way. Scripts must be
written in an appropriate script language but this does
not form part of the HTML specification. Support for
scripting language depends on the browser employed.
The most common scripting language is probably
JavaScript and most modern browsers provide support
but this can sometimes be disabled if desired by the
user.
Nvu allows the use of scripts on pages b ut it does not
respond to them. The effect of the script will not be seen
on the Normal, HTML Tags or Preview view (but the
code will of course appear in Source view).

To see the code at work click on ‘Browse’.
The ‘Insert’ menu does offer one piece of JavaScript, a
calendar. When you click it nothing appears to happen
until you save and run your file on a browser when the
calendar appears!.
In the menu there are commands Tools > Web
Development – JavaScript Console and JavaScript
debugger. I hope to cover this more fully in a later issue
of the Guide.
Note If your page refuses to save after inserting the
Calendar widget use the “Save as” command.

6 Inserts
The menu command Insert provides several options.
Image. See section 3.5.1.
Table. See section 3.6.1.
Form. See section 3.9.
Link. See section 3.7.
Named anchor. See section 3.7.1.3.
Horizontal line. Inserts a horizontal line across the
width of a block at the point selected. This doesn’t have
to be in the simple default style you can define a class
and apply it to customise the line. Alternatively the
Horizontal Line Properties (double click on the line)
allows the width and height, alignment to be set. Colour
can be set via the Advanced Property editor using the
‘Inline Styles’ tab and setting a value for ‘backgroundcolor’.
HTML. Allows you to insert some hand-coded HTML
code at any point on a page. (If you want to add code in
the HEAD area you’ll have to use “Source” view
instead.)
Note If you wish to insert HTML into your page this is
probably the safest way to do so. While you can still
make mistakes in the code Nvu will carry out some
checks and ensure that the result is valid HTML
(whether or not what you intended). Editing in Source
view (see section 3.15) can cause massive corruption
of your page.
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Characters and symbols. Provides a wide range of
characters not readily available from the keyboard
including accented and copyright.
Table of contents. Inserts a table of contents, based on
heading styles which can be selected. The table entries
are linked to the corresponding headings. See section
3.13.
Smart Widgets. Provides a small selection of novelties
(A calendar and ‘Made with Nvu’ – If you’re proud of
your design and that fact that Nvu helped you why not
use it.)

Templates. See section 7.
PHP Code. Clicking opens a window into which PHP
code may be typed or copied. On closing, the code
along with the required php tags is added to the souce
code.
Note Nvu does not support short tags like <? ?> .

Comments are commonly used by coders in order to
improve maintainability of code. Comments do not
appear on a page. Nvu helpfully displays an exclamation
mark in viewing modes other than preview which when
hovered over reveals the content of the comment.
Break below images. If you have an image aligned
right or left (with text wrapping around it) this command
breaks the wrap at the point selected, the text continuing
below the image.
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7 Templates
7.1

What are templates?

Templates are basically pages having some content (eg
a letter head) which can be re-used to create other
pages which will have the same underlying page
structure and, often, the same graphical layout.

Note Useful dummy text can be found at
http://www.lipsum.com/.
Note There are other approaches to page layout but
the method described is simple and reliable.

The figure shows a page prepared as described.

Templates are not altered in use and can be used over
and over again. The simplest template is probably a
blank sheet which links to a stylesheet for use
throughout a site. More common is a page which has a
banner and perhaps a menu to appear on every page.
Last might be a complete page layout for use on all, or
many, pages of a site but which includes areas for
customising individually.
Templates may be considered as having two parts – the
fixed part or ‘boilerplate’ which remains the same for
every page and the editable part which changes.
Nvu recognises two types of editable part. Block and
flow. Block items are like any other html block and may
consist of paragraph-like items or divs (which may
contain several blocks). Blocks may be made repeatable
- so that several similar items may be added if required.
Flow items will be contained within other block items in
line with the text, for instance to change one or two
words in a paragraph.

7.2

Create a new template

7.3

Saving templates

To save a template
1 Click File > Save or File > Save As.
The extension ‘mzt’ will be selected automatically.

7.4

Create a template from a page

Templates are prepared and edited using Nvu just like
any other page.

A pre-existing document may be transformed into a
template

To create a template

1 Click Format > Page Title And Properties

1 Click File > New then select ‘A blank template’ and
‘Create’.

2 Check the box ‘This page is a template’.

Note All templates will be created with the Transitional
HTML Doctype.

2 Add any content which is to appear on all pages
based on the template.

3 Click OK.
4 Click File > Save as The file type ‘HTML Template’
will be completed.
5 Name and save the file as normal.

3 Format this in the normal way.

7.5

4 If the formatting is to be based on a style sheet
prepare this in the normal way as detailed in section
4.2.4.

The content of the page - boilerplate and examples of
editable content - should already be set up and
formatted.

For this to be successful the template must first be
saved.

Setting up template details

To make blocks editable

5 Add the areas which are to be made editable.

1 In turn select each block that you wish to make
editable.

Fill these in using dummy text so that a complete page
layout is achieved even though some of it may be
meaningless. Format this as required.

2 In HTML tags view select the block by clicking its tag.
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3 On the status bar right click the corresponding
highlighted tag.
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4 Click Templates > Make editable.
5 In the ‘Insert an editable area’ window give the block
a recognisable name. Now check the options boxes if
required.
Note The option ‘Area is optional’ allows it to be
deleted easily when the page is in use.
‘Area is repeatable’ allows copies to be made rapidly.
‘Area is moveable’ turns the area into a movable layer
(see section 3.10).
Warning In Nvu 1.0PR this option is disabled

6 Click OK.
To make a flow selection editable
1 In turn select (highlight) each section of text that you
wish to make editable.
2 Click Insert > Templates >Insert editable area.
3 In the ‘Insert an editable area’ window give the block
a recognisable name.
4 Leave checked the option ‘Flow of text’.
5 Check the options boxes if required as described
above.
Note The option ‘Area is moveable’ is inappropriate for
flow areas).

6 Click OK
When you have finished save the template as described
in section 7.3
The figure shows a template at this stage.

be based on a template still loaded (visible) in a page
tab.
Note All pages which Nvu creates which are based on
templates are created as HTML documents using the
Transitional doctype. It is not possible to create XHTML
documents or those with Strict doctypes from
templates.

To create a page
1 Click File > New > A new document based on a
template > Choose File.
2 Select the Template (note templates have the file
extension ‘mzt’)
3 Click ‘Create’.
The page that appears carries
Boilerplate items
Labels for the editable areas within coloured
rectangles (with rounded upper corners).
Sample text (same as the labels) within
surrounding editable boxes (with dashed borders).
To use the page
1 Click in turn in each editable areas.
2 Select and delete the sample text and replace it with
new text.
2a If the editable area was repeatable a small square
appears within the label, hovering turns it red and
clicking makes a copy. Copies have small circles
which act as delete buttons. The next figure
illustrates a template with one flow item (the date)
and one non-repeatable and one repeatable item
repeated once. The first two items have the text
replaced.
Warning - At Nvu 1.0 the text for repeatable items
cannot be edited at this stage however copies may be
made for editing later.

2b If any area was optional a small circle with an x
appears within the label. Hovering turns it red and
clicking deletes it.

7.6

Using templates

To base a page on a template first ensure that the template itself has been saved and closed – a page cannot
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The next figure shows a template at this stage. Because
of the limitation described it has not been possible to fill
in all the editable areas.

The next figure shows the final result. The areas
which could not be edited earlier have been
completed.

Now it is possible to edit any item and as a workaround
the frozen repeatable items may be added.

7.7
3 When all editable boxes have been completed
detach the page from the template by clicking Edit >
Detach from template. The page now assumes its
final appearance.

Editing templates

Templates which have already been saved may be
altered after opening using menu commands File >
Open File and selecting ‘Files of Type’ then ‘HTML
Templates’.
Note The default opening setting is ‘HTML Files’ which
will not open templates.

4 Save the page in the normal way.
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8 Nvu Site Manager
8.1

Overview

The site manager allows you to navigate your site or
between sites easily.
To toggle the Site Manager on or off either press F9 or
use View > Show/Hide > Site Manager.
Site Manager can deal with sites irrespective of whether
they reside on a local machine or on a remote server. In
the latter case, if you are on a dial-up network, Site
Manager will dial and make the connection for you.
Since generally you will set up a site on a local machine
and later 'publish' to a remote server we will deal first
with setting up on a local machine.
Site Manager provides a directory tree view of a site
similar to the view with Windows Explorer. It however
lists only directories which you have specifically set up
as ‘Sites’. You can set up many sites, they appear in
Site Manager irrespective of where they appear in a
normal directory tree.

8.2

Setting up sites

To set up a new site (assuming that pages for the site
have already been created) open Site Manager, click
‘Edit Sites’. This opens the ‘Publish Settings’ window.
Choose a convenient name for the site (You may like to
call it something like “My Site Local” to differentiate it
from a later “My Site Remote”) and enter it in the box
‘Site Name’.
In the ‘Publishing server’ area click ‘Select directory’ and
browse to the folder where the site is located, select the
folder and OK. The box should read something like
“file:///C:/Documents .... “ (Ignore the hint
line which applies to remote sites only.)
Leave the other boxes (Web site information, User
name etc.) blank.
Back in Site Manager in the column headed ‘Name’ the
new site should be listed and can be expanded to show
its contents.

8.3

Double-click any site to expand it.
At the top of the Site Manager window a drop down box
allows you to view all files or to select to view only html
files (which includes htm files) or only image files (these
include gif, jpg, jpeg and png files).
For files it is possible to display the file size and modified
date. To select or de-select these options, in the column
heading click the right-most division and select the
options required (see figure). (You may have to widen
the site manager window to make this possible.)

Site Manager Functions

The main window lists all sites which have been set up
and, for any sites which have been expanded, the files
contained in it. (See figure.)
It is not possible to change the order of the listing.
Double click on any html file to load it directly to the
page area for editing.
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By using the buttons at the top of the Site Manager
window, and selecting a file if required, it is possible to
rename and delete files and to create folders.
Note all these actions alter the actual files concerned.
By using the ‘Edit Sites’ function and the ‘Publish
Settings’ window, sites may be removed from the Site
Manager but this has no effect on the actual folders or
files involved only on the view in Site Manager.

8.4

Section 8.2). This permits the same browsing, display
and editing functions as for a local site.
This time all the boxes on the ‘Publish Settings’ window
must be completed. Hints are provided for the content of
each. The HTTP address will be used by the Site
Manager to find the site..

Remote sites

Remote sites – on the server hosting a site – may be set
.
up in almost exactly the same way as local sites (see
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Warning Remember that any firewall in place must
allow Nvu to access to the site. Unfortunately Nvu
provides little help in resolving any problems which
arise while setting up sites.
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9 Setting Preferences
9.1 Preferences
You can set up a number of features in Nvu according to personal preferences. Several of the options are grouped
under the Tools > Preferences menu. In addition you can customise toolbars via the View > Show/hide menu.
Defaults
Authors may be satisfied by the Nvu default settings however in a number of cases this User Guide recommends
different settings. Although you are at liberty to make changes those made inadvertently may cause problems. The
table lists the default settings, to which you may wish to revert, along with our recommendations where these differ.
Recommendations are marked (R) and the defaults, where they differ by (D). (Some of the text below is
abbreviated to save space.)
Menu selection

Set to

Tools > Preferences> General

Maximum number of pages
Retain original source formatting
Reformat HTML Source
Save images when saving pages
Always show publish dialog
Maintain table layout
Use CSS styles
Always open a document in a new tab

10
Checked (R)
Checked (D)
Checked (D) Cleared (R)
Cleared
Checked
Checked
Checked

Tools > Preferences> Fonts

Allow documents to use other fonts
for others see text

Checked

Tools > Preferences> New Page settings Author
Reader's default colors
Background image
Language
Writing direction
Character set

Blank
Checked
Blank
Blank
No direction specified
ISO-8859-1

Tools > Preferences> Advanced

Direct connection
HTML 4 (R)
Transitional (D) Strict (R)
Checked
Cleared
HTML4 Special characters (D)
Only & < > and non- (R)
Cleared
Cleared

Set up Proxies
Markup - Language
Markup - DTD
Return in paragraph always creates new
Underline misspelled words
Output the following characters
Don't encode '>' outside attribute
Don't encode special characters

9.2 Editing preferences

9.2.1 General group

Nvu can be customised in several ways through the
Menu selection Tools > Preferences mechanism.

Retain original source formatting

All the options may be set at any time. All take effect
immediately except for 'New page settings' which do not
apply to any existing page.
Issued 10-June-2006 based on Nvu version 1.0

The options ‘Retain original source formatting’ and
‘Reformat HTML source’ alter the display in Source view
but have no effect when viewed in a browser.
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‘Retain original source formatting’ often splits lines in
unexpected places but results in the smallest file size.
‘Reformat HTML source’ introduces changes designed
to improve readability such as indenting levels in table
structures. Unfortunately a large number of blank lines
appear in the code which has a counteracting effect and
the indentation is retained in the stored file significantly
increasing its size.
Save images and other associated files when saving
pages.
When saving a file to a new location using 'Save as ..' if
this box is checked the images and style sheets will be
saved to the same folder as the page. This may be
useful occasionally but, where a site is structured with
different kinds of files in different folders, that structure
will not be preserved.
Warning. Not only will the files not be copied to the file
structure specified in the source file but the new saved
file will be altered to reflect the new (flat) structure. If
you wish to use more complex structure on your site,
checking this box will inflict considerable damage to
your file necessitating a lot of rework. The original file in
the original location will however remain as designed.

Always show publish dialog when publishing pages
If checked, Nvu always displays the Publish Page dialog
box when you Publish a page. If not checked, Nvu only
displays the dialog box if it needs more information in
order to publish the page.
Maintain table layout when inserting or deleting
cells
Tables are normally created as a regular matrix i.e.
every row has the same number of cells. With this box
checked inserting a cell in one row should also insert
cells in other rows to maintain regularity. With Nvu 1.0
this does not work.
Use CSS styles instead of HTML elements and
attributes attributes
Originally HTML formatted pages using elements and
attributes. Many of these are not allowed when using
strict doctypes but CSS provides alternatives and
greater flexibility.

browser. Nvu acts in the same way and this area allows
customisation of the choice made. If the box 'Allow
documents to use other fonts' is checked Nvu will use
the font specified in the style or other means. If the box
is unchecked Nvu will not respect styles and will use a
font from the list specified on the upper part of this
window.
The boxes specifying sizes and screen resolution
appear not to work.
9.2.3 New page settings
These define several of the settings used when creating
new pages. (Others will be found on the 'Create a new
document or template' window which appears via the
File > New menu.)
Author's name - Set this if you want the author's name
to appear in the head section of all pages. (For a
specific page this may be set using Format > Page Title
and Properties.)
Readers default colors - Leave this checked. The
alternative of 'Use custom colors' allows the colours of
links to be specified but uses deprecated attributes
which are not permitted for pages using strict doctype.
CSS styles provide alternative means of doing the same
thing. (Section 4.2.5.2).
Background image - Set this if you want a particular
background for all pages.
Language - The main language for the page should be
set to facilitate use by automated tools, for instance
speech synthesisers. Many languages offer
regionalisation alternatives, either select one of these or
use the generic.
Writing direction Usually this may be left at the default
of 'No direction specified'. Setting the language defines
the writing direction.
Character set - Normally for western languages leave
this set to the default of ISO-8859-1. If in doubt set to
UTF-8. You can find more about choice of encoding at
http://www.cs.tut.fi/~jkorpela/www/nvu-enc.html
Note This is badly entitled. It should read 'Character
encoding'. Though it sets a 'charset' parameter it dos
not define a character set.

Always open a document in a new tab

9.2.4 Advanced

When opening pages Nvu normally creates a new tab to
hold it. If this box is checked when a page is opened
using Site Manager a new instance of Nvu is created to
open the page. The previous instance remains
available. This does not apply when pages are opened
by other means.

Set up Proxies - For most people click 'Connection
settings' and check that 'Direct connection' is checked. if
you need to set up proxies refer to Nvu Help.

9.2.2 Fonts
In the absence of a definition of the font to be used a
browser will make a choice on some basis built in to the
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Markup - The Markup language and doctype may be
set as desired. I have recommended the use of Strict
HTML.
Note Properly this should be included under New page
Settings. NB It does not alter an existing page.

Page 38

Nvu User Guide
Return in paragraph always creates new paragraph The action of the Return (Enter) key in or at the end of
text objects is described in the following table.
Return
in paragraph

Return at
end of paragraph

Return
in heading

Return at
end of heading

Box checked New paragraph

New paragraph

New heading

Body

Box cleared

New line

New heading

Body

New line

When the box is checked it is possible to create a new
line in or at the end of a paragraph or heading by
pressing Shift + Enter.
When the box is cleared it is possible to escape from a
paragraph by pressing the Return key twice. This
creates a new paragraph but also leaves a line break at
the end of the previous paragraph. Most people will
prefer to leave the box checked.
The action of the return key in other circumstances
depends on the context, for instance in a table cell it
generates a new line, in a list it creates a new list item.

spell checker separately, however it consumes
resources which may slow the system, in particular the
time taken to switch between views may become
excessive. It is usually better to clear this setting.
Output the following characters as entities - In
normal use this should be set as recommended. No
setting will damage a file but other settings are intended
for use only during development of pages.
Don't encode '>' outside attribute - Set as
recommended.

Don't encode special characters as entities - Set as
Underline misspelled words - When set this is a useful recommended.
reminder to poor spellers or typists who forget to run the
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9.3

Toolbars

9.3.1 Toolbar buttons
Buttons on Composition toolbar
New file

Insert or edit Link

Publish

Insert or edit
Open file

Browse

Form`

Image

Insert or edit

Save file

Insert or edit

Check Spelling

Insert or edit table

named anchor

Print page

Buttons on Format toolbar
Text and
background colour

Bold text

Highlight colour

Italic text

Make text larger

Underline text

Make text smaller

Numbered list

Bulleted list

Justify text

Align text left

Indent text

Align text centre

Outdent text

Align text right

Buttons on Format (2) toolbar (Format toolbar second section)
Layer

Emphasise

Definition
description

Glue to right
border

Bring
forward

Strong
emphasis

Glue to left
border

Glue to top
border

Send back

Definition
term

Stay in
centre

Stay in
middle

Insert
horizontal
line

Left to right

Glue to
bottom

Buttons not normally installed
Cut

Paste

Borders

Right to left

Copy
Find
9.3.2 Customising Toolbars
The list above shows the buttons, and the
corresponding icons, available on Nvu toolbars. The
buttons are normally located on the toolbar indicated. A
button may not be installed by default in which case the
bar may be customised to make it available.
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You can view or hide a number of the toolbars. On the
Menu Bar select View > Show/hide then check which
toolbar you wish to display. You cannot hide the menu
bar.
You can customise some toolbars to change which
items appear on them. To do so right-click on the bar
and select ‘Customize’ then drag an item to or from the
toolbar.
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As you customise a toolbar you can select whether you
wish to display small or large icons. This selection is
specific to each bar.
When customising toolbars three additional symbols will
be found. ‘Separator’ provides a vertical bar to separate
sections on a toolbar, ‘Space’ provides an invisible
space of fixed size. ‘Flexible space’ provides a space
which will expand to fill any space available.

separately, however it consumes resources which may
slow the system, in particular the time taken to switch
between views may become excessive.
For more details of particular options consult the Nvu
Help documentation.
Button

Menu bar selection

Shortcut
with Ctrl

9.3.3 Menu alternatives
Since the Composition Toolbar is often the simplest way
of carrying out a function this guide has generally
assumed that buttons available for that bar are visible. If
you have disabled the Composition or Format toolbar or
a button, functions may be still accessed via the Menu
bar. The corresponding selections are shown in the
table opposite. If there is a shortcut key (with control
key) it is also listed.

9.4

Editing preferences

Nvu can be customised in several ways through the
Menu selection Tools > Preferences mechanism.
There are four sets of options ‘General’, ‘Fonts’, ‘New
page settings’ and ‘Advanced’. Many of the options will
be self-explanatory and need no further explanation.
General – When not using Strict doctype or with ‘Use
CSS Styles …’ unchecked pages use an early form of
HTML.
The options ‘Retain original source formatting’ and
‘Reformat HTML source’ alter the display in Source view
but have no effect when viewed in a browser. Each has
its advantages and disadvantages.
‘Retain original source formatting’ introduces a number
of blank lines, particularly in the head area, but when
files are transferred to other applications e.g. for
validation, line numbers approximately correspond.
‘Reformat HTML source’ does not introduce blank lines
but splits lines so that line numbers correspond poorly.
New page settings – By completing the boxes a
number of items may be added which will appear in the
‘head’ area of all new pages. These include Author’s
name, Language and selections which set the Doctype.
Note Some of these may be overridden for
specific pages using Format > Page Title and
Properties.
Among other options available, when not using Strict
doctype, are colours for links; but better control can be
achieved de-selecting ‘Use custom colors’ and use
styles (Section 4.2.5.2).
Advanced – Setting ‘Return in a paragraph always
creates new paragraph’ can be useful. If un-set a return
creates a line break.
Setting ‘Underline misspelled words’ is a useful reminder
to poor spellers who forget to run the spell checker
Issued 10-June-2006 based on Nvu version 1.0

Anchor
Insert > Named anchor
Align center
Format > Align > Center
Align justify
Format > Align > Justify
Align left
Format > Align > Left
Align right
Format > Align > Right
Bold
Format > Text style > Bold B
Browse
File > Browse page
Bulleted list
Format > List > Bulleted
Choose color for text
Format > Text Color
Choose color for background
n/a
Choose highlight color for text
n/a
Copy
Edit > Copy
C
Cut
Edit > Cut
X
Find
Edit > Find
F
Form
Insert > Form
Horizontal Line Insert > Horizontal line
Image
Insert > Image
Indent text
Format > Increase indent
]
Italic
Format > Text style > Italic I
Larger font size Format > Font size > Larger +
Link
Insert > Link
L
New
File > New
N
Numbered list
Format > List > Numbered
Open
File > Open File
O
Outdent text
Format > Decrease indent [
Paste
Edit > Paste
V
Print
File > Print
P
Publish
File > Publish
Save
File > Save
S
Smaller font size Format > Font size > smaller Spell
Edit > Spell checking
K
Table
Insert > Table
Underline
Format > Text style > Underline U
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10 Publishing to the web
10.1 Introduction

10.2.3 Formal validation

Publishing a site means transferring the site, i.e. the
pages, images and stylesheets involved, to a web
server from which they may be accessed, usually but
not necessarily, by the public. This process is called
‘Uploading’. Prior to publishing there are a few checks
which should be carried out.

Browsers are often very tolerant of incorrect code. A
much more rigorous test is to submit pages to the W3C
validators. There are two: one checks that the page
code conforms to the HTML specification, the second
that the style sheet (internal and external linked) code
conforms to the CSS specification. Nvu provides direct
access to the first of these. You can learn more about
validation at
http://www.gtalbot.org/CCCAWebsite/Valida
tionExplanation.html

10.2 Validating the site
Validating simply means checking that the page or site
operates as intended. Designers may by now have a
plethora of files some of which are obsolete or are not
required for the published site. A good practice is to
create a new folder structure and in it place those files,
and only those files, which are needed.
This can be done using your usual file manager e.g.
Windows Explorer but the Nvu File Manager can be set
up to do this task by ‘Publishing’ these to a new folder.

To validate a page. Open it in Nvu. On the Menu choose
Tools > Validate HTML. A validator window opens and
the page is automatically submitted for validation. The
result will be displayed in the window.

To validate pages with internal stylesheets or separate
external stylesheets the validators may be used
independently. The URLs are given in the References
(Appendix 2). Pages may be validated either from the
10.2.1 Markup Cleaner
local disk or after the files have been uploaded.
Nvu provides a Markup Cleaner Tools > Markup Cleaner
While the W3C validators check rigorously for
which can be used to remove redundant code which
conformity with specifications this does not guarantee
clutters the file but does not contribute to the page
that the code will run correctly. Unfortunately none of the
content. This does not necessarily remove all redundant
current browsers fully support the specifications! This is
content but makes a good contribution to it.
why browser validation is an essential step.
10.2.2 Browser validation
The next stage of validation has already been taken
care of by Nvu. Users have a high assurance that the
code generated represents valid HTML or CSS. The site
should next be run using a browser. Possible problems
include you having omitted to transfer files to the correct
folders, naming the folders incorrectly, including getting
the case wrong. It is also possible that, when you linked
stylesheets, Nvu used absolute addresses instead of
relative addresses (see section 4.2.4.1). Sort these
problems out first.
The site should be checked on a range of different
browsers. Several modern Mozilla based browsers
behave very similarly so do not provide additional
confidence. Check with browsers from other sources
and be very conscious that a few visitors may still be
using very old browsers.
As of early 2006 a minimal set of browsers to test on
might be Firefox (latest version), Opera (latest version),
Internet Explorer 7 (when available) and Internet
Explorer 6. The latter will remain important, and
different, for some time after Internet Explorer 7 is
deployed.
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10.3 Publishing

You can publish your web pages to a web server on
which you have an account. Your ISP probably offers
limited free space but you can buy space from
professional hosting providers.
To publish a site you need to know the settings for the
space so that you can set up your system.
Files may be uploaded using any available FTP program
but Nvu has built-in facilities which are integrated with
the Site Manager which makes this task very simple.
10.3.1 Setting up your site
While setting up Site Manager you may already have
configured the ‘remote’ site (sections 8.4 and 8.2), if not,
either proceed as detailed there, go directly to Publish
Settings via Edit > Publishing Site settings.
Enter the following details:
q In the ‘Site names’ box enter the name that you
want to know the site by.
q HTTP address (URL) of your site. From your ISP
(see hints).
q Publishing address – This is the ftp address to
which you will publish.
q User name – From your ISP.
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q Password – From your ISP.
q If you wish to, check ‘Save Password’.
If you have several sites set up and you have one site
that you always or usually publish to you may wish to
click on the name of this site then ‘Set as default’. This
simplifies uploading.
Click OK.
10.3.2 Uploading
Open the page that you want to upload. An easy way to
do this is from the Site Manager.
1. Click the PUBLISH button.
2. On the ‘Publish Page’ window on the ‘Publish’ tab, if
it is not your default, in the ‘Site name’ box select
8. One possible source of problems occurs if you are
the site to which you want to publish. The ‘Page title’
prevented from accessing the site by a firewall. In
and ’File name’ should already be completed.
this case you may receive a ‘Publishing failed’
message similar to
3. If the page is to be uploaded to a sub-directory,
rather than the root directory, enter the name of a
sub-directory and any of the other data if required.
Note This directory must exist. Nvu cannot create it.

4. If it is the first time to upload the page and if it
includes images or uses external style sheets check
the box ‘Include images and other files’. (If it is not
the first time and these other files have not changed
the box may be left unchecked.) The files will be
placed in the same directory as the page. If you
want them to go in a sub-directory check the box
‘Use this site sub-directory’ and name the directory.
In this case the directory will be created if needed.
Note This is a sub-directory of the root directory not
any directory detailed in the previous point. If you want
to use such a directory this must be explicitly detailed
e.g. pagesubdirectory/filessubdirectory/
Note All the Images and style sheets will be

placed in the same directory. This is the only
arrangement supported by the Site Manager
Publisher.
5. You should not need to refer to the ‘Settings’ tab as
the data should be collected via the Site name you
have selected but you may view the data and
change if you wish.
6. Click ‘Publish’. A ‘Publishing’ window will appear
and uploading will commence. (If you are on a dialup connection this will be connected.)
7. Within a short time you should receive confirmation
of correct publication similar to the figure.

The ‘Troubleshooting’ button takes you to the Nvu help
system but this is short of aid in this area at present.
Other possible problems include
Some required files are missing
File or directory names incorrect e.g. Wrong case
Once you have published a page, if you need to publish
it again, your settings (e.g. subdirectories) should be
remembered by Nvu. You will not see steps 2 to 4 again
unless changes have been made to the page.

C’est fini !
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A1Glossary
This Glossary defines terms as used in this document. As far as possible, when terms used also occur in the HTML or
CSS specifications, they have the same meanings as in those specifications. In such cases more precise definitions may
be obtained there.

Button

A small picture, or icon, which when clicked results in an action. Nvu buttons are of various shapes.

CSS

Cascading Style Sheets.

Declaration

The second part of a style rule. Contains format details of the style.

Deprecated

A feature marked as deprecated is one which is considered obsolete, and whose use is
discouraged. Generally CSS provides better features. Transitional Document types allow the
use of deprecated features. (The ‘Strict’ type does not.)

Directory

Equivalent to what Windows calls a ‘folder’.

Doctype

Document type Declaration - see appendix 3

DTD

Document type Definition - see appendix 3

Element

A small part of a web page such as a paragraph or an image which can be manipulated by a
browser in ways determined by the code associated with the element.

Extension

The final section of a filename (after the dot) indicating the type of file.

FTP

File Transfer Protocol. Used to transfer files to a server.

Handle

Symbols, usually small squares, on the edges of sizing boxes which, when clicked, allow the
size or position to be dragged.

HTML

HyperText Markup Language. The publishing language of the World Wide Web.

ISP

Internet Service Provider.

Mozilla

I use the term to refer to a number of similar browsers including Netscape 6 and later,
Mozilla and Firefox.

MSIE

Microsoft Internet Explorer. The browser from Microsoft Corporation.

Non-breaking space A space character which, though invisible, acts as a normal character in that a ‘word’ which
includes a non-breaking space will not be split to wrap a line.
Nvu

The open source software package (pronounced N-view / ’envju: /, for a ‘new view’) available at http://www.nvu.com, on which this guide is based.

Selector

The first part of a style rule. (May be thought of as the name of the rule.)

Sizing box

A box, denoted by small squares, (Handles) which in Nvu appears around some items when
clicked. See also ‘Handle’.

Strict

see ‘Deprecated’.

Tab (window)

Part of many window structures which emulate the tab on a paper filing system designed to
give quick access to part of the file. If a tab is clicked a new display will appear within the
same window.

Tab (key)

The keyboard key which emulates the action of the tab key on a typewriter.

Tag

A piece of code in a web page associated with an element. Typically each element has a
start tag and an end tag. Tags include an abbreviation for the element name and are
surrounded by angle brackets. E.g. <p> and </p>.

Transitional

see ‘Deprecated’.

Upload (ing)

The process of transferring web files from a local computer to the computer which will host
them on the web.

URL

Uniform Resource Locator. The web address of an item.

W3C

World Wide Web Consortium http://www.w3.org A consortium of the 500 biggest IT corporations who got together to define specifications and recommendations so that a language like
HTML or CSS can inter-operate without problems on different platforms, devices, operating
systems and media.
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A2 References
HTML 4.01 Specification

http://www.w3.org/TR/html4/cover.html

CSS2 Specification

http://www.w3.org/TR/CSS21/

W3C

http://www.w3.org

HTML Validator

http://validator.w3.org/

CSS Validator

http://jigsaw.w3.org/css-validator/

Nvu download site

http://www.nvu.com/download.html
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A3 Doctypes
A 3.1 Introduction
Prior to version 1 Nvu supported only one Doctype
(HTML Transitional). Now users have a choice, so it is
necessary to touch on some aspects of this slightly
esoteric subject.
Doctype abbreviates ‘Document type Declaration’ which
tells a browser which ‘Document type definition’ (DTD)

to use to interpret a page. The Doctype also includes
the URL of a file containing the DTD details.
The Doctype must appear on the first line of code for a
page.
Note Actually on an XHTML page an XML declaration
may precede this but this can result in problems with
some browsers. Nvu does not insert this declaration.
Files without an XML declaration use UTF-8 character
coding.

A 3.2 Doctypes supported
The Doctypes supported by Nvu are
HTML Transitional
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
HTML Strict
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML
"http://www.w3.org/TR/html4/strict.dtd">

4.01//EN"

XHTML Transitional
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
XHTML Strict
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
Note For HTML Doctypes when Nvu inserts a
document type declaration, it omits the URL This has
the undesirable effect of triggering some versions of
MSIE into the so called 'quirks mode'.

A 3.3 Language differences
HTML is the original language of web pages dating from
1990. The latest formulation HTML 4.01 appeared 9
years later. XHTML is essentially the same language so
all modern (and not so modern) browsers render pages
in either language. HTML is quite tolerant, and browser
responses very tolerant, of variations from the norm.
XHTML is much stricter and demands close attention to
detail and has introduced a number of (simple) changes
to back this up. Although HTML will doubtless be longlived XHTML is much more ‘future proof’.
A brief but useful comparison of the two languages will
be found at
http://www.nypl.org/styleguide/xhtml/guidelines.html

An other comparison intended for any wondering which
language to use is at
http://www.webstandards.org/learn/askw3c/oct2003.html

Both HTML and XHTML have Transitional versions
which include features which will eventually be phased
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out. The Strict versions exclude these. In fact browser
support for CSS is now generally so good that there is
no need to create new files using the Transitional
doctype. Transitional versions are useful however for
supporting existing files.
For HTML the Deprecated elements and attributes are
listed in the Index of Elements and Index of attributes
which appear at the end of the specification. (For URL
see appendix 2).
For XHTML a useful comparison will be found at
http://www.zvon.org/xxl/xhtmlReference/
Output/comparison.html

A 3.4 Nvu capability
Nvu can create pages using any of these doctypes.
Pages created from Templates are always generated
using Transitional HTML Doctype.
Note It may be possible to edit a template external to
Nvu and change the doctype so that pages created
from it use the corresponding Doctype. I have not
tested this.

HTML pages created will offer, on saving, the ‘html’
extension, XHTML pages will offer ‘xhtml’ extension.
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The choice is however unimportant to both Nvu and
browsers and may be either ‘htm’, ‘html’ or ‘xhtml’, It is
the Doctype which determines the response.
Note User systems may set up different browsers as
the default for different file types.

Nvu can open and edit pages with any of these
doctypes. The doctype is not editable but Nvu will not
change any doctype encountered.
When creating and editing documents Nvu will generate
code which is appropriate to the doctype declared using
only appropriate elements and attributes. This means
that some features may be disabled or be inaccessible
depending on the type of document encountered.
Typically this may necessitate the use of a CSS style to
obtain some effect which is not accessible using an
HTML attribute.
Nvu will not convert from one doctype to another so, if
the doctype is not consistent with the code on the page,
the result will be unreliable.

A 3.5 Recommendations
Beginners may be rubbing sore heads at this point. For
them my recommendation would be to use Strict HTML.
This may sound odd but it actually increases capability
because it triggers browsers to make better use of CSS
styles.
Throughout the guide, unless otherwise stated, I
describe the action of Nvu when this doctype is in use.

A 3.6 Browser responses
While browsers will render pages irrespective of the
doctype, detailed differences in response occur. A
useful comparison for a number of different browsers for
all the doctypes listed may be found at
http://hsivonen.iki.fi/doctype/
For Internet Explorer 6 rather full details are provided at
http://msdn.microsoft.com/library/default
.asp?url=/library/enus/dnie60/html/cssenhancements.asp

A4 Updating Nvu
Installing Nvu is so straightforward that no explanation
The procedure for updating Nvu is therefore
has been given. From time to time new versions of the
Download the latest version of Nvu from
program are made available at no cost from
http://www.nvu.com/download.html
http://www.nvu.com/ and users will wish to keep up
to date with changes. Updating is easy but not quite as
Make sure that you have a record of your
straightforward as initial installation.
Publishing site settings
Nvu stores a number of settings in files located in the
‘Profiles’ folder. These include some default settings and
details of the sites which you have set up in ‘Site
Manager’ and your ‘Publishing Site Settings’. The Nvu
team recommend that this folder be deleted prior to
installing a new version of Nvu. This means that these
settings will be lost and have to be re-entered following
the new installation. It is advisable to follow this
recommendation.

De-install Nvu in the usual way e.g. From Start
> Settings > Control panel > Add or remove
Programs.
Delete the profiles folder.
Install the new version of Nvu
Set up Site Manager and Publishing Settings
Enjoy using the latest version of Nvu.

The Profiles folder is located at %AppData%\Nvu (i.e.
Something like c:\Documents and
Settings\<login settings>\Application
Data\Nvu).
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A5 Revision History
10-Jun-2006
Rewriten 3.6.5 (subject change), 3.7.2 , 9
Corrections 3.10.7, 4.2.5.3, 4.2.5.4
Minor corrections - Clarification in 3.7.2, Formatting error 4.5.2,
Other amendments/revisions Section 3.7.2, 3.10.5, 4.1.3.3, 4.2.1.1, 4.2.1, 4.2.1.2, 4.2.3.1, 4.3.2.4, 4.5, A3.2 - Note
Minor changes 3.3.2, 3.4.1.2, 3.4.2, 3.6, 3.6.2.1, 3.6.2.4, 4.1.3.2, 4.1.3.4, 4.2.1.1, 4.2.3, 4.4, 4.5, 4.5.1, 4.5.2, 6,
A3.4
15-Jul-2005
Based on Nvu 1.0
06-Jun-2005
Based on Nvu 1.0PR
01-Apr-2005
First version available directly via nvudev.org
17-Mar-2005
Based on Nvu 0.9
07-Feb-2005
Based on Nvu 0.81
25-Jan-2005
Based on Nvu 0.7
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Subject Index
Absolute address.......................... 27
Absolute position.................... 16, 17
Align.............................. 8, 10, 13, 31
Anchors

Document Types......... See: Doctype Image properties........................... 10
Drag and drop........................... 6, 21 Images.......................................... 10
File types.......................................... 35
DTD............................. See: Doctype
Formats............................................ 10
Editing............................................. 6
Inserting........................................... 10
Linking to.......................................... 14 Element..................................... 6, 44
Positioning........................................ 10
Links................................................. 14 Email address
Resizing........................................... 10
Named.............................................. 14

insert................................................ 14

button............................................... 18
Glue to.............................................. 17

Size.................................................. 25
Size - Absolute, relative................... 25
specifying using CSS....................... 24

Author........................................... 41 Expert mode................................. 23 Import text....................................... 9
Background............................ 26, 29 External styles.............................. 22 Indenting text.................................. 9
Inheritance of style properties 18,
Colour............................................... 12 File type
23, 29
Images....................................... 12, 20
Images....................................... 10, 35
Beginner mode............................. 23
Page................................................... 7 Inline styles............................... 8, 22
Block............................................... 7
Stylesheet........................................ 27 Inline text........................................ 7
Block outline............................. 7, 22 Firewall................................... 36, 43 Insert
Caption............................................. 13
Body.............................................. 18 Folder......................... 10, 27, 35, 44
Comment.......................................... 31
Boilerplate..................................... 32 Font
Email address.................................. 14
Bookmark..................................... 14
Colour............................................... 25
Form................................................. 16
Family............................................... 24
Border................... 11, 12, 23, 26, 29
Horizontal line.................................. 31
Box................................................ 26
Break below image....................... 31
Bring to front................................. 17
Calendar....................................... 31
CaScadeS............... See: CSS editor
Cascading..................................... 23
Cells.............................. See: Tables
Centring tables............................. 13
Character set................................ 41
Class names................................. 26
Classes
Applying........................................... 27
Applying to div.................................. 30
Explained......................................... 26
Removing......................................... 27

Colour
Background...................................... 12
Hex value......................................... 25
HSB.................................................. 25
Names.............................................. 25
RGB................................................. 25

Comments.................................... 31
Composition toolbar........................ 5
Contents (table)............................ 19
Contents table.............................. 31
Create table from selection........... 13
CSS
Definition.......................................... 44

CSS Editor

Formatting
Images............................................. 10
Lists.................................................... 9
Tables.............................................. 11
Text.................................................... 7

Forms............................................ 15
Frames.......................................... 15
gif.................................................. 35
Gluing........................................... 17
Handle.......................................... 44
Head............................................. 19
Headings........................................ 7
Help................................................ 4
Horizontal line............................... 31
How to

HTML............................................... 31
Image............................................... 10
Link................................................... 14
Named anchor.................................. 14
Row or Column................................ 12
Script................................................ 31
Symbol............................................. 31
Table................................................ 11
Table of Contents............................. 19
Template.......................................... 32
Text.................................................. 13

Inserts........................................... 31
Internal styles............................... 22
ISP................................................ 44
JavaScript,.................................... 31
jpeg............................................... 35
jpg................................................. 35
Language...................................... 41
align images..................................... 10 Layer....................................... 16, 30
centre a table................................... 13 Line
change link colours.................... 15, 28
create a div....................................... 29
create a layer................................... 16
create a link...................................... 14
insert a named anchor..................... 14
insert a Table of Contents................ 19
insert an email address.................... 14
link to an anchor............................... 14
publish.............................................. 42
set preferences................................ 37
set up forms..................................... 15
use Site Manager............................. 35
validate............................................. 42

modes.............................................. 23
Using................................................ 23 HTML.............................................. 5
Definition.......................................... 44
Description...................................... 6
Inserting........................................... 31
Directory................... See: Folder, 44
variants............................................. 46

Horizontal......................................... 31

Line - new....................................... 7
Link
Colours............................................. 15
Deleting............................................ 15
Editing.............................................. 15

Linking
Images............................................. 15
Text.................................................. 14
to anchors........................................ 14

Links............................................. 14
Lists................................................ 8
ordered............................................... 8

Local site...................................... 35
Made with Nvu.............................. 31
Margin..................................... 26, 29
div element................................... 29
used for layer................................... 16 id................................................... 29 Markup Cleaner............................ 42
Menu bar......................................... 5
Doctype................................ 5, 6, 46
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Nested list....................................... 9
Non breaking spaces...................... 9
Padding............................. 12, 26, 29
Page
File type.............................................. 7
Saving................................................ 7
Title.................................................... 6
Views............................................ 5, 20

Paragraphs..................................... 7
png................................................ 35
Positioning
Absolute........................................... 16

Positioning grid............................. 17
Print................................................ 7
Properties
Class................................................ 27
Link................................................... 14
Lists.................................................... 9
Page................................................... 6
Table (cell)....................................... 13
Text.................................................... 8

pseudo-classes............................. 28
Publish.......................................... 42
Publishing
Default site....................................... 43

Quotes............................................ 9
Relative address........................... 27
Remote site................................... 36
Revision history............................ 48
Rule................... See: Horizontal line
Rulers..................................... 5, 7, 8
Saving
Pages................................................. 7
Stylesheets................................. 27, 28
Templates........................................ 32

Scripts........................................... 31
Selecting items............................. 20
Selectors (style)............................ 28
Send to back................................. 17
Shortcuts....................................... 41
Site Manager............................ 5, 35
Sizing box............................... 10, 44
Smart quotes.................................. 9
Span......................................... 8, 20
Special characters.......................... 9
Spelling checking.......................... 10
Status bar........................... 5, 20, 21
Styles.............................................. 8
Applying to multiple elements.......... 26
Cascading........................................ 23
Creating............................................ 23
External, linked................................. 22
Inline............................................. 8, 22
Internal............................................. 22
Removing......................................... 29

Stylesheet
Creating............................................ 23
Creating external.............................. 27
Creating internal............................... 23
Disabling.......................................... 23
Linking.............................................. 28
Removing......................................... 29
Saving.............................................. 27

Table of Contents......................... 19
Tables........................................... 11
background image............................ 12
Cell alignment.................................. 13
Cell spacing...................................... 12
Centring............................................ 13
Colouring.......................................... 12
creating from selection..................... 13
Inserting Rows etc............................ 12
size................................................... 11

Tag............................................ 6, 44
Text
Formatting.......................................... 7
Indenting............................................ 9
Re-formatting..................................... 8
Width.................................................. 8

Title for page................................... 6
Toolbars.......................................... 5
Tutorial
HTML Introduction.............................. 6

Unique identifiers.......................... 29
Uploading...................................... 42
URL............................................... 44
Validation...................................... 42
Version history.............................. 48
Views........................................ 5, 20
W3C.............................................. 44
Specifications................................... 45

Symbols.................................... 9, 31 Warnings........................... 27, 28, 36
Tab................................................ 44 XHTML
variants............................................. 46
Tab key........................................... 9
z-index.......................................... 17
Table
caption.............................................. 13
Properties......................................... 13

Postscript
This guide started as notes for my personal use. I revealed its existence to the Nvu forums and
received favourable and encouraging remarks so I decided to press on.
I express my thanks to those who have made a number of useful suggestions which I have
incorporated wherever possible. Particular thanks however go to Gérard Talbot who's
knowledge of the web, html and CSS greatly exceeds mine and who has offered a number of
corrections and made a large number of suggestions which I believe have significantly improved
the result. More are in the pipeline awaiting a later version. Mistakes and omissions, of course,
remain mine.
Gérard must also be thanked for undertaking the translation into French as must Tsutomu
Ohmori for translating into Japanese.
Thanks are also due to Daniel Glazman at Disruptive Innovations and to Linspire who have
provided hosting for the files.
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