CIS 221 Lab 7 Configuring and Managing NTFS Security


Lab 7 Configuring and Managing NTFS Security 
This lab contains the following exercises and activities:

· Exercise 7-1: Configuring NTFS Permissions

· Exercise 7-2: Understanding NTFS Permissions

· Lab Review Questions

Scenario
Contoso, Ltd., makes use of many folders that are shared on file servers and locally on multiuser workstations.

To secure these folders, you need to use NTFS permissions to grant access only to users who are members of groups that should have access.

The accounting department has recently installed 20 new workstations, and the IT department is configuring them. Many of these computers are used by multiple users where users share storage locations on the local hard drive. You need to ensure that the correct users have access to these resources, and that others do not.

After completing this lab, you will be able to:

· Configure and understand NTFS permissions.

Before You Begin
This lab requires that you have two volumes on your hard drive: C and L.

Lab 3, Exercises 3-1, "Formatting a Partition;" 3-2, "Converting FAT32 Partitions to NTFS;" and 3-3, "Converting a Basic Disk to a Dynamic Disk" created volume L.

If you have only a C volume, you can complete most of the lab. You will need to skip the section "Copying and Moving Files with NTFS Permissions" in Exercise 7-2, "Understanding NTFS Permissions."

This lab uses the variable xx to refer to your computer number so that your computer name is referred to as Computerxx.

Exercise 7-1: Configuring NTFS Permissions

A computer that has multiple users logging on locally (not to the Contoso domain, but to Computerxx) needs to have a shared folder for use by accountants secured using NTFS permissions.

First, you need to create an Accountants group. This group should be allowed to create files in the shared folder but not to modify files that others have created. Administrators should maintain full control. However, other users should not have access to the folder.

Creating a Group and User Account

The following steps will create the Accountants group and two example users.

1. Log on with your local Administrator credintials.

2. From the Start menu, right-click My Computer and then select Manage.

3. In the Computer Management console, in the console tree, under System Tools, expand Local Users And Groups and then select Groups, as shown in the following figure.
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4. From the Action menu, select New Group.

5. In the New Group dialog box, in the Group Name text box, type Accountants and then click Create. 
6. Click Close.

7. In the Computer Management console, in the console tree, select Users.

8. From the Action menu, select New User.

9. In the New User dialog box, in the User Name text box, type AllenB. In the Full Name text box, type Allen Brewer.

10. In the Password and Confirm Password text boxes, type P@sswOrd.

11. Clear the User Must Change Password At Next Logon check box, and select the Password Never Expires check box. Click Create.

12. In the User Name text box, type JayH. In the Full Name text box, type Jay Hamlin.

13. In the Password and Confirm Password text boxes, type P@sswOrd.

14. Clear the User Must Change Password At Next Logon check box, and select the Password Never Expires check box. Click Create, and then click Close.

15. In the Computer Management console, in the details pane, right-click AllenB and then select Properties.

16. In the AllenB Properties dialog box, on the Member Of tab, click Add.

17. In the Select Groups dialog box, in the Enter The Object Names To Select (Examples) text box, type Computerxx\Accountants and then click Check Names. 
18. Click OK.
Question 1: What other group is Allen a member of? 
19. In the AllenB Properties dialog box, click OK.

20. Add Jay Hamlin to the Accountants group also, by completing steps 14 through 19 with JayH.

21. Close the Computer Management console.
Configuring Permissions

The following will create two folders and set the NTFS permissions of the first folder to the specifications for the shared accountants folder specified in the exercise scenario.

1. From the Start menu, select My Computer.

2. In the My Computer window, double-click Local Disk (C:).

3. From the File menu, Point to New and then select Folder.

4. For the name of the folder, type Share 1 On Volume 1 and then press ENTER
5. Create another folder in the same location named Share 2 on Volume 1.

6. Right-click Share 1 On Volume 1, and then select Properties.

7. In the Share 1 On Volume 1 Properties dialog box, on the Security tab, click Add.

8. In the Select Users, Computers, Or Groups dialog box, in the Enter The Object Names To Select (Examples) text box, type Computerxx\Accountants and then click Check Names. 
9. Click OK.

Question 2: What three permissions for Accountants are set to Allow by default?

10. In the Group Or User Names list, select Users and then click Remove. 
Question 3: Why can't you remove the Users group (read completely what it says in the dialog box)?

11. In the Security message box, click OK.

12. In the Share 1 On Volume 1 Properties dialog box, on the Security tab click Advanced.

13. In the Advanced Security Settings For Share 1 On Volume 1 dialog box, on the Permissions tab, clear the Inherit From Parent The Permission Entries That Apply To Child Objects. Include These With Entries Explicitly Defined Here check box.
Question 4: What information is presented in the dialog box that appears? 
14. In the Security message box, click Copy.

15. In the Advanced Security Settings For Share 1 On Volume 1 dialog box, in the Permissions Entries list box, ensure that Accountants (COMPUTERxx\ Accountants) is selected and then click Edit.
Question 5: What Allow permissions are set for the Object? 
16. In the Permissions Entry For Share 1 On Volume 1 dialog box, in the Permissions list box, select the Allow check box for the Create Files/Write Data permission, Click OK.

17. In the Advanced Security Settings For Share 1 On Volume 1 dialog box, click OK.

18. In the Share 1 On Volume 1 Properties dialog box, ensure that in the Group Or User Names list box, Users (COMPUTERxx\ Users) is selected, and then click Remove. 
19. Click OK.
Testing Permissions

The following steps will test the permissions that you have set, to make sure that they work as intended.

1. Log off and log on as AllenB (using the password P@sswOrd) to the local computer.

2. From the Start menu, select My Computer.

3. In the My Computer window, double-click Local Disk (C:).

4. In the Local Disk (C:) window, click Show The Contents Of This Folder.

5. Double-click Share 1 On Volume 1.

6. In the Share 1 On Volume 1 window, from the File menu, point to New and then select Text Document.

7. For the name of the text document, type AllenB's Document and then press ENTER. Double-click the document to open it.

8. In Notepad, type Allen's text.

9. From the File menu, select Exit and save the changes when asked.

10. Log off and log back on as JayH to the local computer.

11. Browse to Share 1 On Volume 1 (steps 2 through 5 of this task).

12. Double-click AllenB's Document.

Question 6: Can you read the contents of AllenB's Document?

13. In Notepad, type the following line after Allen's text: Jay's text.

14. From the File menu, select Save.

Question 7: Can you save the changes you made to AllenB's Document?

Question 8: Why were you able to save changes to the file when you were logged on as AllenD, but not JayH, when you are both members of the Accountants group?

Question 9: We assigned the Accountants group the Create Files / Write Data special permission on the Share 1 On Volume 1 folder. Why isn't the Write Data portion of this permission enough to allow you to write as JayH to a file created by another user, as long as it is in the Share 1 On Volume 1 folder?

15. In the Notepad message box, click OK.

16. In the Save As dialog box, click Cancel.

17. From the File menu, select Exit, and click No when asked if you want to save changes.

18. Log off.
Exercise 7-2: Understanding NTFS Permissions

You have been asked to audit the NTFS permissions for various objects for particular groups or users. Rather than look at the permissions explicitly, you need to view the effective permissions for various groups.

Effective Permissions 
The following steps will reveal effective permissions.

1. Log on with your local Administrator credentials.

2. From the Start menu, select My Computer.
3. In the My Computer window, double-click Local Disk (C:)
4. Right-click Share 1 On Volume 1, and then select Properties
5. In the Share 1 On Volume Properties dialog box, on the Security tab, ensure that in the Group Or User Names list box, Accountants is selected.

6. In the Permissions For Accountants list box, clear all but the Allow check box for the Read permission, and then click Apply. Click Advanced.

7. In the Advanced Security Settings For Share 1 On Volume 1 dialog box, on the Effective Permissions tab, click Select.

8. In the Select User, Computer, Or Group text box, in the Enter The Object Name To Select (Examples) text box, type Computerxx\Accountants and then click Check Names. 
9. Click OK.

Question 10: What are the effective permissions that are granted to the Accountants group for the Share 1 On Volume 1 folder?

10. Click Select.

11. In the Select User, Computer, Or Group text box, in the Enter The Object Name To Select (Examples) text box, type Computerxx\Administrator and then click Check Names. 
12. Click OK.

Question 11: What are the effective permissions that are granted to the local Administrator account for the Share 1 On Volume 1 folder?
13. In the Advanced Security Settings For Share 1 On Volume 1 dialog box, on the Effective Permissions tab, click OK.

14. In the Share 1 On Volume 1 dialog box, click OK.

15. In the Local Disk (C:) window, double-click Share 1 On Volume 1 to open it.

16. Right-click AllenB's Document, and then click Properties.

17. In the AllenB's Document.txt Properties dialog box, on the Security tab, click Advanced.

18. In the Advanced Security Settings For AllenB's Document.txt dialog box, on the Effective Permissions tab, click Select.

19. In the Select User, Computer, Or Group text-box, in the Enter The Object Name To Select (Examples) text box, type Computerxx\AllenB and then click Check Names. 
20. Click OK.

Question 12: The Accountants group only explicitly allows a subset of all permissions, but AllenD has all effective permissions for the file AllenIB's Document. Why?

21. In the Advanced Security Settings For AllenB's Document dialog box, click OK.

22. In the AllenB's Document.txt Properties dialog box, click OK.

23. Leave the Share 1 On Volume 1 window open for the next task.
Understanding the Relationship Between Permissions and Special Permissions

To be sure that you have been assigning only the necessary permissions, you have been specifying special permissions explicitly. But it is often easier to allow a permission that is made of several special permissions. So that you can use this shortcut, you need to understand the relationship between permissions and the special permissions that they are made from.

1. In the Share 1 On Volume 1 folder, click the Up button.

2. In the Local Disk (C:) window, right-click Share 1 On Volume 1 and then select Properties.

3. In the Share 1 On Volume 1 Properties dialog box, on the Security tab, ensure that in the Group Or User Names list box the Accountants group is selected.

4. Select the Allow check box for the Full Control permission, and then clear all check boxes.

 Note:  The reason you select the Allow check box for the Full Control permission first is that it forces the Allow check box for the Special Permissions permission to clear.

5. Select the Allow check box for the Modify permission.

Question 13: What other Allow check boxes are selected when you select the Modify check box?

6. Clear all the check boxes, and then select the Allow check box for the Read & Execute permission.

Question 14: When you select the Allow check box for the Read & Execute permission, what other Allow check boxes are selected?

7. Clear all check boxes. Select the Allow check box for the List Folder Contents permission, and then click Advanced.

8. In the Advanced Security Settings For Share 1 On Volume 1 dialog box, ensure that Accountants (COMPUTERxx \Accountants) is selected, and then click Edit.

9. Use the Permission Entry For Share 1 On Volume 1 dialog box to answer the inline questions that follow it.

Question 15: What special permissions constitute the List Folder Contents permission?

10. Examine what special permissions make up the other permissions in a similar way, and be prepared to answer questions on it in the "Lab Review Questions" section of the this lab. You might want to answer the review questions now.
11. When you are done, ensure that only the Allow check box for the List Folder Contents permission is selected for the Share 1 On Volume 1 folder for the Accountants group, as shown in the following figure, and then click OK.
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12. Leave the Local Disk (C:) window open for the next task.

Copying and Moving Files with NTFS Permissions

You have been asked to copy and move some folders that are used by multiple users. You need to understand how this will affect the permissions on the folders so that you can ensure that those who need access have it, and those who don't need it, don't have it.

1. In the Local Disk (C:) window, CTRL + double-click Share 2 On Volume 1. This will open Share 2 On Volume 1 in a new window.

2. From the Start menu, select My Computer.

3. In the My Computer window, double-click Data (L:). Three windows should now be open: Local Disk (C:), Share2 On Volume 1, and Data (L:).
4. Right-click in a blank area of the start bar and select Tile Windows vertically, the desktop should look like the following figure.
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5. In the Local Disk (C:) window, select Share 1 On Volume 1, and from the Edit menu, select Copy.

6. From the Edit menu, select Paste. A folder named Copy Of Share 1 On Volume 1 is created.

7. In the Data (L:) window, from the Edit menu, select Paste. Right-click the Share 1 On Volume 1 folder that was just created, and select Rename.

8. For the name, type Copied and then press ENTER.

9. In the Local Disk (C:) window, right-click Copy Of Shared 1 On Volume 1 and then select Properties.

10. In the Copy Of Share 1 On Volume 1 Properties dialog box, on the Security tab, examine the Group Or User Names list.

Question 16: Does the Accountants group appear in the list?

11. Add the Accountants group (as in Exercise 7-1), and make sure only the Allow check box for the List Folder Contents permission is selected for the Accountants group. 
12. Click OK.

13. In the Local Disk (C:) window, select Share 1 On Volume 1, and from the Edit menu, select Cut.

14. In the Share 2 On Volume 1 window, from the Edit menu, select Paste.

15. In the Local Disk (C:) window, select Copy Of Share 1 On Volume 1 and from the Edit menu, select Cut.

16. In the Data (L:) window, from the Edit menu, select Paste. Rename the pasted folder Moved.

17. Examine the Security tabs in the Properties for the folders you moved and copied, and complete the following chart.

	
	Moved

Within NTFS Volume
	Copied

Within NTFS Volume
	Moved to Other NTFS Volume
	Copied to Other NTFS Volume

	Retained NTFS Permissions
	
	
	
	

	Did Not Retain NTFS Permissions (inherited them from destination folder instead)
	
	
	
	



16.  Close all open Windows

Lab Review Questions

1. You have added an account to a group that has the Write permission for a folder, but you are still unable to write to the folder. What could be causing this?

2. When you block permission entries from being inherited from a parent, you are asked what you want to do with the current permissions that were inherited. What are the two options?
3. What special permissions constitute the Write permission?
4. A user belongs to six separate groups, all with different permissions. You are trying to figure out what permissions the user has by mapping them by hand. What is an easier way to find out what his permissions are when his membership to all the groups is taken into account?
5. A user has copied a data file using a CD burner from a Windows 98 computer and transferred the file to a Windows XP computer. When the application that uses the data file is started, an "access is denied" error appears and references the data file. What might be the problem?
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